summaryrefslogtreecommitdiff
path: root/net-libs/libpcap/libpcap-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-libs/libpcap/libpcap-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-libs/libpcap/libpcap-9999.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index f240ac606d96..a6571d9395c0 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools git-r3 multilib-minimal ltprune
+EAPI=7
+inherit autotools git-r3 multilib-minimal
DESCRIPTION="A system-independent library for user-level network packet capture"
EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
@@ -13,7 +13,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-IUSE="bluetooth dbus netlink static-libs usb"
+IUSE="bluetooth dbus netlink -remote static-libs usb -yydebug"
KEYWORDS=""
RDEPEND="
@@ -30,7 +30,7 @@ DEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.9.0-pcap-config-includedir.patch
+ "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
"${FILESDIR}"/${PN}-9999-prefix-darwin.patch
)
@@ -45,8 +45,11 @@ multilib_src_configure() {
econf \
$(use_enable bluetooth) \
$(use_enable dbus) \
+ $(use_enable remote) \
$(use_enable usb) \
- $(use_with netlink libnl)
+ $(use_enable yydebug) \
+ $(use_with netlink libnl) \
+ --enable-ipv6
}
multilib_src_compile() {
@@ -60,7 +63,8 @@ multilib_src_install_all() {
if ! use static-libs; then
find "${ED}" -name '*.a' -exec rm {} + || die
fi
- prune_libtool_files
+
+ find "${ED}" -name '*.la' -delete || die
# We need this to build pppd on G/FBSD systems
if [[ "${USERLAND}" == "BSD" ]]; then