summaryrefslogtreecommitdiff
path: root/net-libs/libpcap/libpcap-1.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-libs/libpcap/libpcap-1.9.1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-libs/libpcap/libpcap-1.9.1.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-1.9.1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/net-libs/libpcap/libpcap-1.9.1.ebuild b/net-libs/libpcap/libpcap-1.9.1.ebuild
deleted file mode 100644
index 4775c7d9c5b4..000000000000
--- a/net-libs/libpcap/libpcap-1.9.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools multilib-minimal ltprune
-
-DESCRIPTION="A system-independent library for user-level network packet capture"
-HOMEPAGE="
- https://www.tcpdump.org/
- https://github.com/the-tcpdump-group/libpcap
-"
-SRC_URI="
- https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="bluetooth dbus netlink static-libs usb"
-
-RDEPEND="
- bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
- dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
- netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
- virtual/yacc
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${PN}-${P/_}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.1-usbmon.patch
- "${FILESDIR}"/${PN}-1.9.0-pcap-config-includedir.patch
-)
-
-src_prepare() {
- default
-
- echo ${PV} > VERSION || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable bluetooth) \
- $(use_enable dbus) \
- $(use_enable usb) \
- $(use_with netlink libnl) \
- --disable-rdma \
- --enable-ipv6
-}
-
-multilib_src_compile() {
- emake all shared
-}
-
-multilib_src_install_all() {
- dodoc CREDITS CHANGES VERSION TODO README.* doc/README.*
-
- # remove static libraries (--disable-static does not work)
- if ! use static-libs; then
- find "${ED}" -name '*.a' -exec rm {} + || die
- fi
- prune_libtool_files
-
- # We need this to build pppd on G/FBSD systems
- if [[ "${USERLAND}" == "BSD" ]]; then
- insinto /usr/include
- doins pcap-int.h portability.h
- fi
-}