summaryrefslogtreecommitdiff
path: root/net-libs/libpcap/libpcap-1.9.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-libs/libpcap/libpcap-1.9.1-r2.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-libs/libpcap/libpcap-1.9.1-r2.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-1.9.1-r2.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/net-libs/libpcap/libpcap-1.9.1-r2.ebuild b/net-libs/libpcap/libpcap-1.9.1-r2.ebuild
deleted file mode 100644
index 89890d0941fb..000000000000
--- a/net-libs/libpcap/libpcap-1.9.1-r2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools multilib-minimal
-
-DESCRIPTION="A system-independent library for user-level network packet capture"
-HOMEPAGE="
- https://www.tcpdump.org/
- https://github.com/the-tcpdump-group/libpcap
-"
-SRC_URI="
- https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="bluetooth dbus netlink -remote static-libs usb -yydebug"
-
-RDEPEND="
- bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
- dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
- netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
- usb? ( virtual/libusb:1[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
- virtual/yacc
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${PN}-${P/_}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.1-usbmon.patch
- "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
-)
-
-src_prepare() {
- default
-
- echo ${PV} > VERSION || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable bluetooth) \
- $(use_enable dbus) \
- $(use_enable remote) \
- $(use_enable usb) \
- $(use_enable yydebug) \
- $(use_with netlink libnl) \
- --disable-rdma \
- --enable-ipv6
-}
-
-multilib_src_compile() {
- emake all shared
-}
-
-multilib_src_install_all() {
- dodoc CREDITS CHANGES VERSION TODO README.* doc/README.*
-
- # remove static libraries (--disable-static does not work)
- if ! use static-libs; then
- find "${ED}" -name '*.a' -exec rm {} + || die
- fi
-
- find "${ED}" -name '*.la' -delete || die
-
- # We need this to build pppd on G/FBSD systems
- if [[ "${USERLAND}" == "BSD" ]]; then
- insinto /usr/include
- doins pcap-int.h portability.h
- fi
-}