summaryrefslogtreecommitdiff
path: root/net-libs/libpcap/libpcap-1.9.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /net-libs/libpcap/libpcap-1.9.1-r1.ebuild
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'net-libs/libpcap/libpcap-1.9.1-r1.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-1.9.1-r1.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/net-libs/libpcap/libpcap-1.9.1-r1.ebuild b/net-libs/libpcap/libpcap-1.9.1-r1.ebuild
deleted file mode 100644
index 704e1bbe519a..000000000000
--- a/net-libs/libpcap/libpcap-1.9.1-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools multilib-minimal
-
-DESCRIPTION="A system-independent library for user-level network packet capture"
-HOMEPAGE="
- https://www.tcpdump.org/
- https://github.com/the-tcpdump-group/libpcap
-"
-SRC_URI="
- https://github.com/the-tcpdump-group/${PN}/archive/${P/_}.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="bluetooth dbus netlink -remote static-libs usb -yydebug"
-
-RDEPEND="
- bluetooth? ( net-wireless/bluez:=[${MULTILIB_USEDEP}] )
- dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
- netlink? ( dev-libs/libnl:3[${MULTILIB_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
- virtual/yacc
- dbus? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
-"
-
-S=${WORKDIR}/${PN}-${P/_}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.1-usbmon.patch
- "${FILESDIR}"/${PN}-1.9.1-pcap-config.patch
-)
-
-src_prepare() {
- default
-
- echo ${PV} > VERSION || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" \
- econf \
- $(use_enable bluetooth) \
- $(use_enable dbus) \
- $(use_enable remote) \
- $(use_enable usb) \
- $(use_enable yydebug) \
- $(use_with netlink libnl) \
- --enable-ipv6
-}
-
-multilib_src_compile() {
- emake all shared
-}
-
-multilib_src_install_all() {
- dodoc CREDITS CHANGES VERSION TODO README.* doc/README.*
-
- # remove static libraries (--disable-static does not work)
- if ! use static-libs; then
- find "${ED}" -name '*.a' -exec rm {} + || die
- fi
-
- find "${ED}" -name '*.la' -delete || die
-
- # We need this to build pppd on G/FBSD systems
- if [[ "${USERLAND}" == "BSD" ]]; then
- insinto /usr/include
- doins pcap-int.h portability.h
- fi
-}