summaryrefslogtreecommitdiff
path: root/net-libs/libnsl/libnsl-1.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-libs/libnsl/libnsl-1.3.0-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-libs/libnsl/libnsl-1.3.0-r1.ebuild')
-rw-r--r--net-libs/libnsl/libnsl-1.3.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libnsl/libnsl-1.3.0-r1.ebuild b/net-libs/libnsl/libnsl-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..5a5cdfc6f771
--- /dev/null
+++ b/net-libs/libnsl/libnsl-1.3.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Public client interface for NIS(YP) and NIS+ in a IPv6 ready version"
+HOMEPAGE="https://github.com/thkukuk/libnsl"
+SRC_URI="https://github.com/thkukuk/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0/2"
+LICENSE="LGPL-2.1+"
+
+# Stabilize together with glibc-2.26!
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="
+ >=net-libs/libtirpc-1.2.0[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<sys-libs/glibc-2.26
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.0-rpath.patch
+)
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}