summaryrefslogtreecommitdiff
path: root/net-libs/libnipper/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libnipper/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libnipper/files')
-rw-r--r--net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch16
-rw-r--r--net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch13
-rw-r--r--net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch13
3 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch b/net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch
new file mode 100644
index 000000000000..45b65b5e0383
--- /dev/null
+++ b/net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch
@@ -0,0 +1,16 @@
+ https://bugs.gentoo.org/423813
+
+
+ device/device.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/device/device.cpp
++++ b/device/device.cpp
+@@ -31,6 +31,7 @@
+
+
+ // Includes...
++#include <unistd.h>
+ #include "../globaldefs.h"
+ #include "errortext.h"
+ #include "device.h"
diff --git a/net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch b/net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch
new file mode 100644
index 000000000000..332276e14329
--- /dev/null
+++ b/net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch
@@ -0,0 +1,13 @@
+diff --git a/device/common/misc.cpp b/device/common/misc.cpp
+index 7b3a7fb..612aacd 100644
+--- a/device/common/misc.cpp
++++ b/device/common/misc.cpp
+@@ -198,7 +198,7 @@ const char *Device::cidrToNetmask(const char *cidr)
+ unsigned int Device::ipAddressToNum(const char *address)
+ {
+ // Variables...
+- char *addressPointer = 0;
++ const char *addressPointer = 0;
+ unsigned int returnAddress = 0;
+ int tempInt = 0;
+
diff --git a/net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch b/net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch
new file mode 100644
index 000000000000..471236b84f92
--- /dev/null
+++ b/net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4cc6260..d4518fb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -319,7 +319,7 @@ SET(libnipper_SRC
+ ADD_LIBRARY(nipper SHARED ${libnipper_SRC})
+
+ # Install...
+-INSTALL(TARGETS nipper LIBRARY DESTINATION /usr/lib)
++INSTALL(TARGETS nipper LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ INSTALL(FILES nipper.conf DESTINATION /etc)
+ INSTALL(FILES libnipper.h config.h DESTINATION /usr/include/libnipper/)
+ INSTALL(FILES man/nipper.conf.5 DESTINATION /usr/share/man/man5)