summaryrefslogtreecommitdiff
path: root/net-libs/libnftnl/libnftnl-1.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-libs/libnftnl/libnftnl-1.1.7.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-libs/libnftnl/libnftnl-1.1.7.ebuild')
-rw-r--r--net-libs/libnftnl/libnftnl-1.1.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/libnftnl/libnftnl-1.1.7.ebuild b/net-libs/libnftnl/libnftnl-1.1.7.ebuild
new file mode 100644
index 000000000000..992fe51d51ef
--- /dev/null
+++ b/net-libs/libnftnl/libnftnl-1.1.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info toolchain-funcs usr-ldscript
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="https://netfilter.org/projects/nftables/"
+SRC_URI="https://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/11" # libnftnl.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-libs/libmnl-1.0.4"
+BDEPEND="virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a nftnl
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete || die "Could not rm examples"
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}