summaryrefslogtreecommitdiff
path: root/net-libs/libnet/libnet-1.2_rc3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libnet/libnet-1.2_rc3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libnet/libnet-1.2_rc3.ebuild')
-rw-r--r--net-libs/libnet/libnet-1.2_rc3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-libs/libnet/libnet-1.2_rc3.ebuild b/net-libs/libnet/libnet-1.2_rc3.ebuild
new file mode 100644
index 000000000000..c541794f8e7d
--- /dev/null
+++ b/net-libs/libnet/libnet-1.2_rc3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
+HOMEPAGE="http://libnet-dev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}-dev/${P/_/-}.tar.gz"
+
+LICENSE="BSD BSD-2 HPND"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc static-libs"
+
+DEPEND="sys-devel/autoconf"
+RDEPEND=""
+
+DOCS=(
+ README doc/{CHANGELOG,CONTRIB,DESIGN_NOTES,MIGRATION}
+ doc/{PACKET_BUILDING,PORTED,RAWSOCKET_NON_SEQUITUR,TODO}
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2-rc.patch
+ eautoreconf
+}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ docinto sample
+ dodoc sample/*.[ch]
+ fi
+
+ use static-libs || prune_libtool_files
+}