summaryrefslogtreecommitdiff
path: root/net-libs/libnatpmp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /net-libs/libnatpmp/files
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'net-libs/libnatpmp/files')
-rw-r--r--net-libs/libnatpmp/files/libnatpmp-20150609-gentoo.patch (renamed from net-libs/libnatpmp/files/remove-static-lib-20130911.patch)49
-rw-r--r--net-libs/libnatpmp/files/remove-static-lib.patch44
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20130911.patch53
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20140401.patch36
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS.patch40
-rw-r--r--net-libs/libnatpmp/files/respect-libdir-20120821.patch20
-rw-r--r--net-libs/libnatpmp/files/respect-libdir.patch19
7 files changed, 36 insertions, 225 deletions
diff --git a/net-libs/libnatpmp/files/remove-static-lib-20130911.patch b/net-libs/libnatpmp/files/libnatpmp-20150609-gentoo.patch
index a2c1f516c363..41593a041582 100644
--- a/net-libs/libnatpmp/files/remove-static-lib-20130911.patch
+++ b/net-libs/libnatpmp/files/libnatpmp-20150609-gentoo.patch
@@ -1,7 +1,17 @@
-diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
---- libnatpmp-20130911.orig/Makefile 2013-09-13 07:00:55.874343916 -0400
-+++ libnatpmp-20130911/Makefile 2013-09-13 07:03:33.733351101 -0400
-@@ -35,7 +35,6 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,8 +4,9 @@
+ # (c) 2007-2013 Thomas Bernard
+ # http://miniupnp.free.fr/libnatpmp.html
+
++GENTOO_LIBDIR ?= lib
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install -p
+ ARCH = $(shell uname -m | sed -e s/i.86/i686/)
+ VERSION = $(shell cat VERSION)
+@@ -35,7 +36,6 @@
OBJS = $(LIBOBJS) testgetgateway.o natpmpc.o natpmp-jni.o
@@ -9,7 +19,7 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
ifeq ($(OS), Darwin)
SHAREDLIB = libnatpmp.dylib
JNISHAREDLIB = libjninatpmp.dylib
-@@ -58,7 +57,7 @@
+@@ -58,11 +58,11 @@
HEADERS = natpmp.h
@@ -18,7 +28,12 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
INSTALLPREFIX ?= $(PREFIX)/usr
INSTALLDIRINC = $(INSTALLPREFIX)/include
-@@ -72,9 +71,9 @@
+-INSTALLDIRLIB = $(INSTALLPREFIX)/lib
++INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
+ INSTALLDIRBIN = $(INSTALLPREFIX)/bin
+
+ JAVA ?= java
+@@ -74,9 +74,9 @@
.PHONY: all clean depend install cleaninstall installpythonmodule
@@ -30,7 +45,7 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
python setup.py build
touch $@
-@@ -82,18 +81,17 @@
+@@ -84,18 +84,17 @@
python setup.py install
clean:
@@ -51,7 +66,7 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
$(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
$(INSTALL) -d $(INSTALLDIRBIN)
$(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
-@@ -142,20 +140,13 @@
+@@ -147,25 +146,18 @@
$(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
$(RM) $(INSTALLDIRLIB)/$(SONAME)
$(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
@@ -61,14 +76,22 @@ diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
$(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-natpmpc-static: natpmpc.o $(STATICLIB)
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
natpmpc-shared: natpmpc.o $(SHAREDLIB)
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+-
-$(STATICLIB): $(LIBOBJS)
- $(AR) crs $@ $?
--
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
$(SHAREDLIB): $(LIBOBJS)
ifeq ($(OS), Darwin)
- $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+
diff --git a/net-libs/libnatpmp/files/remove-static-lib.patch b/net-libs/libnatpmp/files/remove-static-lib.patch
deleted file mode 100644
index dae64601b9cb..000000000000
--- a/net-libs/libnatpmp/files/remove-static-lib.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- libnatpmp-20110715/Makefile
-+++ libnatpmp-20110715/Makefile
-@@ -33,7 +32,7 @@
-
- HEADERS = natpmp.h
-
--EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
-+EXECUTABLES = testgetgateway natpmpc-shared
-
- INSTALLPREFIX ?= $(PREFIX)/usr
- INSTALLDIRINC = $(INSTALLPREFIX)/include
-@@ -45,9 +44,9 @@
-
- .PHONY: all clean depend install cleaninstall installpythonmodule
-
--all: $(STATICLIB) $(SHAREDLIB) $(EXECUTABLES)
-+all: $(SHAREDLIB) $(EXECUTABLES)
-
--pythonmodule: $(STATICLIB) libnatpmpmodule.c setup.py
-+pythonmodule: libnatpmpmodule.c setup.py
- python setup.py build
- touch $@
-
-@@ -55,11 +54,10 @@
- depend:
- makedepend -f$(MAKEFILE_LIST) -Y $(OBJS:.o=.c) 2>/dev/null
-
--install: $(HEADERS) $(STATICLIB) $(SHAREDLIB) natpmpc-shared
-+install: $(HEADERS) $(SHAREDLIB) natpmpc-shared
- $(INSTALL) -d $(INSTALLDIRINC)
- $(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
- $(INSTALL) -d $(INSTALLDIRLIB)
-- $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
- $(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
- $(INSTALL) -d $(INSTALLDIRBIN)
- $(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
-@@ -76,7 +74,6 @@
- $(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
- $(RM) $(INSTALLDIRLIB)/$(SONAME)
- $(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
-- $(RM) $(INSTALLDIRLIB)/$(STATICLIB)
-
- testgetgateway: testgetgateway.o getgateway.o
-
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch b/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch
deleted file mode 100644
index df36e2d4a4a0..000000000000
--- a/net-libs/libnatpmp/files/respect-FLAGS-20130911.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
---- libnatpmp-20130911.orig/Makefile 2013-09-10 16:15:06.000000000 -0400
-+++ libnatpmp-20130911/Makefile 2013-09-12 13:20:29.191447842 -0400
-@@ -5,7 +5,7 @@
- # http://miniupnp.free.fr/libnatpmp.html
-
- OS = $(shell uname -s)
--CC = gcc
-+CC ?= gcc
- INSTALL = install
- VERSION = $(shell cat VERSION)
-
-@@ -22,6 +22,7 @@
- # APIVERSION is used in soname
- APIVERSION = 1
- #LDFLAGS = -Wl,--no-undefined
-+GENTOO_CFLAGS := $(CFLAGS)
- CFLAGS = -Os
- #CFLAGS = -g -O0
- CFLAGS += -fPIC
-@@ -52,6 +53,8 @@
- endif
- endif
-
-+CFLAGS := $(CFLAGS) $(GENTOO_CFLAGS)
-+
- HEADERS = natpmp.h
-
- EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
-@@ -144,19 +147,19 @@
- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- natpmpc-static: natpmpc.o $(STATICLIB)
-- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- natpmpc-shared: natpmpc.o $(SHAREDLIB)
-- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- $(STATICLIB): $(LIBOBJS)
- $(AR) crs $@ $?
-
- $(SHAREDLIB): $(LIBOBJS)
- ifeq ($(OS), Darwin)
-- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
- else
-- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
- endif
-
-
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
deleted file mode 100644
index 0a007b169a79..000000000000
--- a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur libnatpmp-20140401.orig/Makefile libnatpmp-20140401/Makefile
---- libnatpmp-20140401.orig/Makefile 2013-12-09 15:52:28.000000000 -0500
-+++ libnatpmp-20140401/Makefile 2014-04-02 10:03:42.128609226 -0400
-@@ -5,7 +5,7 @@
- # http://miniupnp.free.fr/libnatpmp.html
-
- OS = $(shell uname -s)
--CC = gcc
-+CC ?= gcc
- INSTALL = install -p
- ARCH = $(shell uname -m | sed -e s/i.86/i686/)
- VERSION = $(shell cat VERSION)
-@@ -153,19 +153,19 @@
- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- natpmpc-static: natpmpc.o $(STATICLIB)
-- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- natpmpc-shared: natpmpc.o $(SHAREDLIB)
-- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
-
- $(STATICLIB): $(LIBOBJS)
- $(AR) crs $@ $?
-
- $(SHAREDLIB): $(LIBOBJS)
- ifeq ($(OS), Darwin)
-- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
- else
-- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
- endif
-
-
diff --git a/net-libs/libnatpmp/files/respect-FLAGS.patch b/net-libs/libnatpmp/files/respect-FLAGS.patch
deleted file mode 100644
index 0338d1810e67..000000000000
--- a/net-libs/libnatpmp/files/respect-FLAGS.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- libnatpmp-20110808/Makefile
-+++ libnatpmp-20110808/Makefile
-@@ -4,13 +4,12 @@
- # http://miniupnp.free.fr/libnatpmp.html
-
- OS = $(shell uname -s)
--CC = gcc
-+CC ?= gcc
- INSTALL = install
-
- # APIVERSION is used in soname
- APIVERSION = 1
--#LDFLAGS = -Wl,--no-undefined
--CFLAGS = -O -fPIC -Wall -DENABLE_STRNATPMPERR
-+CFLAGS := -Wall -DENABLE_STRNATPMPERR $(CFLAGS)
-
- LIBOBJS = natpmp.o getgateway.o
-
-@@ -75,16 +75,18 @@
- testgetgateway: testgetgateway.o getgateway.o
-
- natpmpc-shared: natpmpc.o $(SHAREDLIB)
-- $(CC) $(LDFLAGS) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-+
-+getgateway.o natpmp.o: CFLAGS += -fPIC
-
- $(STATICLIB): $(LIBOBJS)
- $(AR) crs $@ $?
-
- $(SHAREDLIB): $(LIBOBJS)
- ifeq ($(OS), Darwin)
-- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
- else
-- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^
- endif
-
- # DO NOT DELETE
diff --git a/net-libs/libnatpmp/files/respect-libdir-20120821.patch b/net-libs/libnatpmp/files/respect-libdir-20120821.patch
deleted file mode 100644
index 90b7167a1d4f..000000000000
--- a/net-libs/libnatpmp/files/respect-libdir-20120821.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur libnatpmp-20120821.orig/Makefile libnatpmp-20120821/Makefile
---- libnatpmp-20120821.orig/Makefile 2012-08-26 20:26:27.000000000 -0400
-+++ libnatpmp-20120821/Makefile 2012-08-26 20:27:07.000000000 -0400
-@@ -4,6 +4,7 @@
- # (c) 2007-2011 Thomas Bernard
- # http://miniupnp.free.fr/libnatpmp.html
-
-+GENTOO_LIBDIR ?= lib
- OS = $(shell uname -s)
- CC ?= gcc
- INSTALL = install
-@@ -41,7 +42,7 @@
-
- INSTALLPREFIX ?= $(PREFIX)/usr
- INSTALLDIRINC = $(INSTALLPREFIX)/include
--INSTALLDIRLIB = $(INSTALLPREFIX)/lib
-+INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
- INSTALLDIRBIN = $(INSTALLPREFIX)/bin
-
- .PHONY: all clean depend install cleaninstall installpythonmodule
diff --git a/net-libs/libnatpmp/files/respect-libdir.patch b/net-libs/libnatpmp/files/respect-libdir.patch
deleted file mode 100644
index 07f5d87ddf98..000000000000
--- a/net-libs/libnatpmp/files/respect-libdir.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- libnatpmp-20110808/Makefile
-+++ libnatpmp-20110808/Makefile
-@@ -6,6 +6,7 @@
- # (c) 2007-2011 Thomas Bernard
- # http://miniupnp.free.fr/libnatpmp.html
-
-+GENTOO_LIBDIR ?= lib
- OS = $(shell uname -s)
- CC ?= gcc
- INSTALL = install
-@@ -36,7 +37,7 @@
-
- INSTALLPREFIX ?= $(PREFIX)/usr
- INSTALLDIRINC = $(INSTALLPREFIX)/include
--INSTALLDIRLIB = $(INSTALLPREFIX)/lib
-+INSTALLDIRLIB = $(INSTALLPREFIX)/$(GENTOO_LIBDIR)
- INSTALLDIRBIN = $(INSTALLPREFIX)/bin
-
- .PHONY: all clean depend install cleaninstall installpythonmodule