summaryrefslogtreecommitdiff
path: root/net-libs/liblockfile/liblockfile-1.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /net-libs/liblockfile/liblockfile-1.15.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'net-libs/liblockfile/liblockfile-1.15.ebuild')
-rw-r--r--net-libs/liblockfile/liblockfile-1.15.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/liblockfile/liblockfile-1.15.ebuild b/net-libs/liblockfile/liblockfile-1.15.ebuild
new file mode 100644
index 000000000000..4bd4389ffac0
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs multilib
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="https://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="acct-group/mail"
+DEPEND="${RDEPEND}"
+
+DOCS=( Changelog README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ # I don't feel like making the Makefile portable
+ [[ ${CHOST} == *-darwin* ]] \
+ && cp "${FILESDIR}"/Makefile.Darwin.in Makefile.in
+
+ eautoreconf
+}
+
+src_configure() {
+ local grp=mail
+ if use prefix ; then
+ # we never want to use LDCONFIG
+ export LDCONFIG=${EPREFIX}/bin/true
+ # in unprivileged installs this is "mail"
+ grp=$(id -g)
+ fi
+ econf --with-mailgroup=${grp} --enable-shared
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}