summaryrefslogtreecommitdiff
path: root/net-libs/libktorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /net-libs/libktorrent
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'net-libs/libktorrent')
-rw-r--r--net-libs/libktorrent/Manifest2
-rw-r--r--net-libs/libktorrent/libktorrent-2.1.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/libktorrent/Manifest b/net-libs/libktorrent/Manifest
index 3d3e458a3bf9..55084634a242 100644
--- a/net-libs/libktorrent/Manifest
+++ b/net-libs/libktorrent/Manifest
@@ -1,4 +1,6 @@
AUX libktorrent-2.1-unused-link.patch 649 BLAKE2B 246274feed30df570ba174699b48c702a9b77bbbdda66d7ae44fa0a83993a007897ed2cc9193a4ddd8aba6c8ddc4b1319694246c0bb6bae94bf4dfc4c1591588 SHA512 94f2663bef9c5d31ebdc69538a4dc80b17b9f6835c4975f5b52f13a6bc03ba526b50ee91e1b4515c426e80e95e64f41e8d38980585638a4eb15c328e37fe6ac4
+DIST libktorrent-2.1.1.tar.xz 357516 BLAKE2B 8bcec166fa1d4f09b72c4f31c771d5316f7411da538b789b111b641c8ba551d9c88bd1d68d8ad96396e125bb6b16f9d4e2a42a6b2166b40572d730d692d3cf5d SHA512 5c7f0218193cae148b03ae86a886b89d08a46200755728468ef271a6201add88eca617898d486d1823699def282d0251e26e3b28d2642f45cab966c286127d37
DIST libktorrent-2.1.tar.xz 355476 BLAKE2B c86205174ac0526455cc9d2049cd918fa1127e85ca18422823f89c3714950d6e4f606dabbeca4d615a17fc18d8032ef0cf86aa4d80726116ea667d9f257e0ddc SHA512 28d7a4b8ee45ddcbadb3ca9d6e568120803081b0ecd3e9436ed721860717b98538c522653ea47975123f0819548d0cabe1973baffed887fcbbca11d84ea5ebe4
EBUILD libktorrent-2.1-r2.ebuild 1355 BLAKE2B 6b8e1600b6c8eeb8d447166aeac2310cfc3de7b3ec50df02a087bc8306ed53ef6cb21a9dfb453a136c86ff85d87794db6ac06f17b87edceb6cb731f08f58ab64 SHA512 e11dd93dd788c50b93871d3c1bc8c34fd13bbc3db041933b31a0ab29c3b22f412e31186b977e5347e23b65f04620954e425edfda08302bc09b1122f07b3a2771
+EBUILD libktorrent-2.1.1.ebuild 1348 BLAKE2B e2e563a158b9be304a206f6359d7965b367d238893b979bc65b257a216ce253fb61e1b5785c530104ea752b79eac80988758b33eb7adac86adf6525e35d79e7d SHA512 22e76136f24c9783b6a0948d6bf7dd3504d9cdfabed4e14acb5d733e1eeac747867982c9c36e94da1add7bf63ca316b8500454691a9469ad21d672fea7d97154
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/net-libs/libktorrent/libktorrent-2.1.1.ebuild b/net-libs/libktorrent/libktorrent-2.1.1.ebuild
new file mode 100644
index 000000000000..d9c041e72e83
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-2.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="BitTorrent library based on KDE Frameworks"
+HOMEPAGE="https://kde.org/applications/internet/ktorrent/"
+SRC_URI="mirror://kde/stable/ktorrent/5.1.2/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="sys-devel/gettext"
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxml)
+ app-crypt/qca:2[qt5(+)]
+ >=dev-libs/gmp-6.0.0a:0=
+ dev-libs/libgcrypt:0=
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/boost
+"
+RDEPEND="${COMMON_DEPEND}
+ !dev-libs/botan[gmp(-)]
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.1-unused-link.patch" ) # git master
+
+src_prepare() {
+ kde5_src_prepare
+
+ # Gentoo workaround because gmp.h in MULTILIB_WRAPPED_HEADERS is breaking this
+ sed -i -e "/^find_package/ s/\"\${LibGMP_MIN_VERSION}\" //" \
+ CMakeLists.txt || die
+ sed -i -e "/^find_dependency/ s/ \"@LibGMP_MIN_VERSION@\"//" \
+ KF5TorrentConfig.cmake.in || die
+}
+
+src_test() {
+ # failing network tests
+ local myctestargs=(
+ -E "(fin|packetloss|send|transmit)"
+ )
+
+ kde5_src_test
+}