summaryrefslogtreecommitdiff
path: root/net-libs/libiscsi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 17:43:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 17:43:52 +0100
commit560358ad7081e6bb2a4e097d4c442b0bab626163 (patch)
treea6b7139b78fc7e22cc555611541081774c1fc8eb /net-libs/libiscsi/files
parent1d412f04b6e137f20cbe616b3203d2cbc8dfd5ad (diff)
gentoo auto-resync : 10:05:2023 - 17:43:52
Diffstat (limited to 'net-libs/libiscsi/files')
-rw-r--r--net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch b/net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch
new file mode 100644
index 000000000000..89d91c5c5ebf
--- /dev/null
+++ b/net-libs/libiscsi/files/libiscsi-1.19.0_p20230208-fix-rdma-automagic.patch
@@ -0,0 +1,24 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -166,6 +166,8 @@ if test x"$libiscsi_cv_HAVE_SG_IO" = x"yes"; then
+ AC_DEFINE(HAVE_SG_IO,1,[Whether we have SG_IO support])
+ fi
+
++AC_ARG_WITH([rdma], AS_HELP_STRING([--with-rdma], [Build with rdma support]))
++
+ AC_CACHE_CHECK([for iSER support],libiscsi_cv_HAVE_LINUX_ISER,[
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <infiniband/verbs.h>
+@@ -173,10 +175,10 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <rdma/rdma_verbs.h>]],
+ [[int ibv = IBV_WC_SEND;]])],
+ [libiscsi_cv_HAVE_LINUX_ISER=yes],[libiscsi_cv_HAVE_LINUX_ISER=no])])
+-if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes"; then
++if test x"$libiscsi_cv_HAVE_LINUX_ISER" = x"yes" && test "x$with_rdma" = "xyes"; then
+ AC_DEFINE(HAVE_LINUX_ISER,1,[Whether we have iSER support])
+ fi
+-AM_CONDITIONAL([HAVE_LINUX_ISER], [test $libiscsi_cv_HAVE_LINUX_ISER = yes])
++AM_CONDITIONAL([HAVE_LINUX_ISER], [test "x$with_rdma" = "xyes"])
+
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <rdma/rdma_cma.h>]], [[return RDMA_OPTION_ID_ACK_TIMEOUT;]])],[AC_DEFINE([HAVE_RDMA_ACK_TIMEOUT],[1],[Define to 1 if you have RDMA ack timeout support])],[])