summaryrefslogtreecommitdiff
path: root/net-libs/libiio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /net-libs/libiio
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'net-libs/libiio')
-rw-r--r--net-libs/libiio/Manifest4
-rw-r--r--net-libs/libiio/libiio-0.15-r1.ebuild27
-rw-r--r--net-libs/libiio/libiio-9999.ebuild27
-rw-r--r--net-libs/libiio/metadata.xml18
4 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/libiio/Manifest b/net-libs/libiio/Manifest
new file mode 100644
index 000000000000..cf9c19dc2e73
--- /dev/null
+++ b/net-libs/libiio/Manifest
@@ -0,0 +1,4 @@
+DIST libiio-0.15.tar.gz 192704 BLAKE2B 7eeaad1535f69ca11fe3f716ac70a161f98d24513fe910cb34ca11a0b63c07f5b5321447c96c247cc9a76ed838d806fa9f160e87fd10f1aeac5025edfa16b8f6 SHA512 7e3ca1a8b97486f20baf38afecfd26c626bed1fef535d88020d11eb4e49fc1226390c6383799222f6811c13b8b7e5cc77fb899c776c150a9d1c2024bf8ab338b
+EBUILD libiio-0.15-r1.ebuild 662 BLAKE2B e59b4222302bc9a4f52e561f3c710460198ade34f65588d33fcbd55afe9536f965d96283ae244968f3d855dd6cc8bbf24107d1b1fcbd8147018919285dc0ab0e SHA512 3f669cadb91c1697387d8484206ee6733c49fc16d937c73ca0830e0bcbb629af5f1d7c4c9635e2232876df638b09f5666898fa3a5ac7e35e5eaaa63c61935158
+EBUILD libiio-9999.ebuild 662 BLAKE2B e59b4222302bc9a4f52e561f3c710460198ade34f65588d33fcbd55afe9536f965d96283ae244968f3d855dd6cc8bbf24107d1b1fcbd8147018919285dc0ab0e SHA512 3f669cadb91c1697387d8484206ee6733c49fc16d937c73ca0830e0bcbb629af5f1d7c4c9635e2232876df638b09f5666898fa3a5ac7e35e5eaaa63c61935158
+MISC metadata.xml 506 BLAKE2B a3be5b15b8043c7e52b3a3ed6a01dab5731286ba3266285426ef8c56bd1124fbf8a2b3083cad85094ff5d0ac0f06a6127ccbfcdc89502d909797deacb14aabb9 SHA512 c408630124499db22c21e2f2911fb7dd023f1e704b895c770c2510a08f7b3516cc83aa8d50a6e6aa2c0365ca7e91064a1cb664ce80e1ba153d68a381182264ba
diff --git a/net-libs/libiio/libiio-0.15-r1.ebuild b/net-libs/libiio/libiio-0.15-r1.ebuild
new file mode 100644
index 000000000000..64bf1679f217
--- /dev/null
+++ b/net-libs/libiio/libiio-0.15-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Library for interfacing with IIO devices"
+HOMEPAGE="https://github.com/analogdevicesinc/libiio"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/libiio"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+aio +avahi"
+
+RDEPEND="dev-libs/libxml2:=
+ virtual/libusb:1=
+ aio? ( dev-libs/libaio )
+ avahi? ( net-dns/avahi )"
+DEPEND="${RDEPEND}"
diff --git a/net-libs/libiio/libiio-9999.ebuild b/net-libs/libiio/libiio-9999.ebuild
new file mode 100644
index 000000000000..64bf1679f217
--- /dev/null
+++ b/net-libs/libiio/libiio-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Library for interfacing with IIO devices"
+HOMEPAGE="https://github.com/analogdevicesinc/libiio"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/libiio"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+aio +avahi"
+
+RDEPEND="dev-libs/libxml2:=
+ virtual/libusb:1=
+ aio? ( dev-libs/libaio )
+ avahi? ( net-dns/avahi )"
+DEPEND="${RDEPEND}"
diff --git a/net-libs/libiio/metadata.xml b/net-libs/libiio/metadata.xml
new file mode 100644
index 000000000000..01dc3884d2c9
--- /dev/null
+++ b/net-libs/libiio/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ <name>Radio</name>
+ </maintainer>
+ <use>
+ <flag name="aio">Enable asynchronous IO support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">analogdevicesinc/libiio</remote-id>
+ </upstream>
+</pkgmetadata>