summaryrefslogtreecommitdiff
path: root/net-libs/libiio/libiio-0.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-19 08:36:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-19 08:36:10 +0100
commit19a10140592052698d68be11db5a59bc88fcf528 (patch)
tree4af8926304f638633a3b9d0947126950c8cb01a0 /net-libs/libiio/libiio-0.24.ebuild
parentd1989de9d66ba4285e46f80cd571d5a82beae871 (diff)
gentoo auto-resync : 19:08:2022 - 08:36:10
Diffstat (limited to 'net-libs/libiio/libiio-0.24.ebuild')
-rw-r--r--net-libs/libiio/libiio-0.24.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/libiio/libiio-0.24.ebuild b/net-libs/libiio/libiio-0.24.ebuild
new file mode 100644
index 000000000000..8c0f8320c620
--- /dev/null
+++ b/net-libs/libiio/libiio-0.24.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake udev
+
+DESCRIPTION="Library for interfacing with IIO devices"
+HOMEPAGE="https://github.com/analogdevicesinc/libiio"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/libiio"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+aio +zeroconf"
+
+RDEPEND="dev-libs/libxml2:=
+ virtual/libusb:1=
+ aio? ( dev-libs/libaio )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}