summaryrefslogtreecommitdiff
path: root/net-libs/libhtp/libhtp-0.5.42.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 14:56:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 14:56:29 +0000
commitcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (patch)
tree9b90516b35ff9055066e5b8f2e4a2ce3b6a71b38 /net-libs/libhtp/libhtp-0.5.42.ebuild
parent5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (diff)
gentoo auto-resync : 02:12:2022 - 14:56:29
Diffstat (limited to 'net-libs/libhtp/libhtp-0.5.42.ebuild')
-rw-r--r--net-libs/libhtp/libhtp-0.5.42.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/libhtp/libhtp-0.5.42.ebuild b/net-libs/libhtp/libhtp-0.5.42.ebuild
new file mode 100644
index 000000000000..5bbe9e699afb
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.42.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+IUSE="debug"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The debug configure logic is broken.
+ econf $(usev debug '--enable-debug')
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+}