summaryrefslogtreecommitdiff
path: root/net-libs/libgssglue/libgssglue-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libgssglue/libgssglue-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libgssglue/libgssglue-0.4.ebuild')
-rw-r--r--net-libs/libgssglue/libgssglue-0.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libgssglue/libgssglue-0.4.ebuild b/net-libs/libgssglue/libgssglue-0.4.ebuild
new file mode 100644
index 000000000000..651e2aeed115
--- /dev/null
+++ b/net-libs/libgssglue/libgssglue-0.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="exports a gssapi interface which calls other random gssapi libraries"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="!app-crypt/libgssapi"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.3-protos.patch \
+ "${FILESDIR}"/${PN}-0.4-implicit-declarations.patch
+}
+
+src_configure() {
+ # No need to install static libraries, as it uses libdl
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ insinto /etc
+ doins doc/gssapi_mech.conf
+}