summaryrefslogtreecommitdiff
path: root/net-libs/libdmapsharing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-30 22:03:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-30 22:03:23 +0100
commited6e9ebb6ab4abd792d5b15e97ec245603dd6e2d (patch)
treee1f5f93f2986a4038351e6cf4804eb0c2aad060d /net-libs/libdmapsharing
parent8b63b46fda85d54cfbe94df2444a3ddd3e63b8e4 (diff)
gentoo auto-resync : 30:03:2023 - 22:03:23
Diffstat (limited to 'net-libs/libdmapsharing')
-rw-r--r--net-libs/libdmapsharing/Manifest2
-rw-r--r--net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/libdmapsharing/Manifest b/net-libs/libdmapsharing/Manifest
index 51b9a6ae5906..00f41bb2f2f2 100644
--- a/net-libs/libdmapsharing/Manifest
+++ b/net-libs/libdmapsharing/Manifest
@@ -1,3 +1,5 @@
DIST libdmapsharing-2.9.41.tar.gz 765880 BLAKE2B d64245ef6ffefb7a3f8b6c994e385427afe9b1aa22882da3f2fad82457fda6c48bea61314c6f4b8e82888284e98f4202338582dab2fd412c5e5cc96d7ff5f145 SHA512 304ba87428a39d2b9fd6d4cdc196f59e1aaf2ce3bb15f30acc2c9ca51ec8f86c9b499cf46cf938231e3088808475daba4fc55c44bcbef693be1b500dae4ab028
+DIST libdmapsharing-3.9.12.tar.gz 801055 BLAKE2B 121437f448e90a655fd6e999c9e1696c8377f10c41d3f8f59d4bad1af9ed29051523d799bc259a20305a976aa98aa0b10b5c8e761a2a55c023374282d4e0abe1 SHA512 c75667640371cdfe77088d10f77b668b4bb841aeef5ff9e1a08ce9903bd9a29f1d3184d790da9f87b78967636eedf00bb3299ff675acc82b9316eaca3c0ac41f
EBUILD libdmapsharing-2.9.41.ebuild 1249 BLAKE2B 6f793651b467a9bc018d0c7d1ead857edad29f1f6712f7a1b252a47f18dd9b0a0ecc8ab11739c8384584d63d893c9be71a3dc8b546cae91898df44cfb28734fb SHA512 7c0e79aea4c53b0513e75a04f974761c9d752c7d2d99ecad48270fc8aa552986cea26302cf0a244f81375b6ecd2245599d18cf4ce7c7605dd700ce4b50a5308f
+EBUILD libdmapsharing-3.9.12.ebuild 1269 BLAKE2B 5d72e673bea751a020113bb8aa4e713220d00e2f16c83abfa7d25c6f6872b17e1c4cd36badb00ae3aa371d5475b2c25e5620f6a717e45a6995edb821f61f0d50 SHA512 b290cf1a1876c614984a3bdac6932675ee9f48e959ad14420ca90ff27fede8db98ee730c7fa0a6e2002e519e8cd8241b9ebd8c3028f6d7487fb1bf6af128a496
MISC metadata.xml 355 BLAKE2B 632a659df8a315710cfb4225481954ee02b53052aade7b02df8e4e1487370e76c1aefdd49969becc4c1a9bd5b9d33d205851341f26c6c8a5a6f0b1f6a8a451e5 SHA512 6db709a190e5adb531aeaf9b5f0834fc3f4c9fe1a3d18fda3689e41d553740bbc5d21ac2cde7ea55fd9281a8f2561f6be00243dad301ca900769c064c8e8c94b
diff --git a/net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild b/net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild
new file mode 100644
index 000000000000..5c0d72ba5425
--- /dev/null
+++ b/net-libs/libdmapsharing/libdmapsharing-3.9.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="A library that implements the DMAP family of protocols"
+HOMEPAGE="https://www.flyn.org/projects/libdmapsharing/"
+SRC_URI="https://www.flyn.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="4.0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection test"
+RESTRICT="!test? ( test ) test" # TODO: Tests require Avahi mDNS to be running
+
+# Vala/libgee/gtk+:2 is only used when maintainer-mode is enabled
+# Doesn't seem to be used for anything...
+RDEPEND="
+ >=dev-libs/glib-2.66:2
+ x11-libs/gdk-pixbuf:2
+ >=net-dns/avahi-0.6[dbus]
+ net-libs/libsoup:3.0
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.4 )
+"
+
+src_prepare() {
+ # Remove useless CFLAGS alteration in configure
+ sed -e 's/CFLAGS -O2/CFLAGS/' -i configure || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-mdns=avahi \
+ $(use_enable introspection) \
+ $(use_enable test tests)
+}