summaryrefslogtreecommitdiff
path: root/net-libs/libcrafter/libcrafter-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libcrafter/libcrafter-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libcrafter/libcrafter-9999.ebuild')
-rw-r--r--net-libs/libcrafter/libcrafter-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libcrafter/libcrafter-9999.ebuild b/net-libs/libcrafter/libcrafter-9999.ebuild
new file mode 100644
index 000000000000..561ca127a53c
--- /dev/null
+++ b/net-libs/libcrafter/libcrafter-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils git-r3
+
+DESCRIPTION="a high level library for C++ designed to make easier the creation and decoding of network packets"
+HOMEPAGE="https://github.com/pellegre/libcrafter"
+EGIT_REPO_URI="https://github.com/pellegre/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}