summaryrefslogtreecommitdiff
path: root/net-libs/libbtbb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /net-libs/libbtbb
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'net-libs/libbtbb')
-rw-r--r--net-libs/libbtbb/Manifest2
-rw-r--r--net-libs/libbtbb/libbtbb-2018.08.1.ebuild156
2 files changed, 158 insertions, 0 deletions
diff --git a/net-libs/libbtbb/Manifest b/net-libs/libbtbb/Manifest
index 97ec2d003cb5..7e9b5d76d250 100644
--- a/net-libs/libbtbb/Manifest
+++ b/net-libs/libbtbb/Manifest
@@ -1,4 +1,6 @@
DIST libbtbb-2017-03-R2.tar.gz 303689 BLAKE2B d36cf5329fb31cd50f64e3a9b625ebca8bf198794073480baa4f64935f4bef183e4c11f0844cd31df943da98c778bdea807fbd91676c23a3a2f830af5e7a185f SHA512 bb7b58a33198fd64fba5f0254cfbb71120c70476d594a7aaf82c77f770d1a6e89b4571f42d3d15c1d93d5246c9145c33ba8724a5ee5ad84e96f748d9f32275b5
+DIST libbtbb-2018-08-R1.tar.gz 310542 BLAKE2B 0ae945c530c476caadfd7786f34eca4d7efd71c2f27a37c7b0242a1d3fba80e985c76a0635a354184aa80039ca8ac11f59778f550cbe9bb7e8a535723396cab0 SHA512 63fa995b51f2246b6f27d8aa1bd7a5c0276414df9d13d432d9a1a7ad78ac06e4c67fe3dcf00cf1634f11d6e999f13633591a3347d4e533fff4f131f8deee922e
EBUILD libbtbb-2017.03.2.ebuild 3653 BLAKE2B f289661bdb77b5544333de760fa1de2a93f66ccf9e9c3a1c552d9ff033cb8d2d09d55648f228a6f50d2bdf650f7a95e7357ed79a4f273534effea09b3aa163bd SHA512 ab2bce27d74c21af2bf5a1702c1d650756ed6fd1968d4ac8d575e6f9e28867f4e71fcf940154d9d35482a13d1eb4b04bcd4dea48ebe73487fbddf18b650b0e08
+EBUILD libbtbb-2018.08.1.ebuild 3653 BLAKE2B 3051f5e34d3c75805df4d8b3d3022e096e3c48b0d9a1c170fddd2776af094931c1d4f9081a8f1c14164cda9f11aca5e991fc0f80e40bc79c2e52a9734ac67d2e SHA512 be843fadcc02138fed0f8f7d6ada75a9540e1faa27a6d2eba208d87c8a7af36ac7f099f44d9410201c8ce0967c31b63311df1a938caa5ecdaed00a5e6b29f474
EBUILD libbtbb-9999.ebuild 3653 BLAKE2B f289661bdb77b5544333de760fa1de2a93f66ccf9e9c3a1c552d9ff033cb8d2d09d55648f228a6f50d2bdf650f7a95e7357ed79a4f273534effea09b3aa163bd SHA512 ab2bce27d74c21af2bf5a1702c1d650756ed6fd1968d4ac8d575e6f9e28867f4e71fcf940154d9d35482a13d1eb4b04bcd4dea48ebe73487fbddf18b650b0e08
MISC metadata.xml 568 BLAKE2B 508af89d4b95fa71c32b5a610e1630938dc8bf7b83a98b5af981de1a3a70ec0775d694ba5e5514f83e9abdbcb229500080fc31225de40bb65ad347cb273f44a5 SHA512 a4425e207724117d83fcd21f2ed5f9bd52a945597c19ee253c1c55b1e62f0f3d14d71c546cf2e2d6c7ad7b48b0e88ef3d46fc2a172f86cb00c710ed87946430e
diff --git a/net-libs/libbtbb/libbtbb-2018.08.1.ebuild b/net-libs/libbtbb/libbtbb-2018.08.1.ebuild
new file mode 100644
index 000000000000..998113cc4029
--- /dev/null
+++ b/net-libs/libbtbb/libbtbb-2018.08.1.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="A library to decode Bluetooth baseband packets"
+HOMEPAGE="http://libbtbb.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S=${WORKDIR}/${PN}-${MY_PV}
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="extras static-libs wireshark-plugins"
+
+RDEPEND="extras? ( ${PYTHON_DEPS} )
+ wireshark-plugins? (
+ >=net-analyzer/wireshark-1.8.3-r1:=
+ )
+"
+DEPEND="${RDEPEND}
+ wireshark-plugins? ( dev-libs/glib
+ virtual/pkgconfig )"
+
+REQUIRED_USE="extras? ( ${PYTHON_REQUIRED_USE} )"
+
+get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+
+which_plugins() {
+ if has_version '>=net-analyzer/wireshark-2.2.0'; then
+ plugins=""
+ elif has_version '>=net-analyzer/wireshark-1.12.0'; then
+ plugins="btbb btbredr"
+ elif has_version '<net-analyzer/wireshark-1.12.0'; then
+ plugins="btbb btle btsm"
+ fi
+}
+
+src_prepare(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_prepare
+
+ if use wireshark-plugins; then
+ which_plugins
+ for i in ${plugins}
+ do
+ sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_prepare
+ done
+ fi
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ local mycmakeargs=(
+ -DENABLE_PYTHON=$(usex extras)
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ -DBUILD_ROOT="${ED}"
+ )
+ cmake-utils_src_configure
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
+ )
+ cmake-utils_src_configure
+ done
+ fi
+}
+
+src_compile(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_compile
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_compile
+ done
+ fi
+}
+
+src_test(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_test
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_test
+ done
+ fi
+}
+
+src_install(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_install
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_install
+ done
+ fi
+}