summaryrefslogtreecommitdiff
path: root/net-libs/libbitcoinconsensus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /net-libs/libbitcoinconsensus
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'net-libs/libbitcoinconsensus')
-rw-r--r--net-libs/libbitcoinconsensus/Manifest3
-rw-r--r--net-libs/libbitcoinconsensus/libbitcoinconsensus-0.17.1.ebuild94
2 files changed, 97 insertions, 0 deletions
diff --git a/net-libs/libbitcoinconsensus/Manifest b/net-libs/libbitcoinconsensus/Manifest
index 1df18491b08a..bc82b709a74c 100644
--- a/net-libs/libbitcoinconsensus/Manifest
+++ b/net-libs/libbitcoinconsensus/Manifest
@@ -1,4 +1,7 @@
DIST bitcoin-0.16.3.knots20180918.patches.tar.xz 466344 BLAKE2B c45b96513e4b6317e6a2a55cc3b47302fbe56fb87717ae0197010694013331b5d071b85a11a73c76f08f39e9f0294d3475e89ee63272047df83893de4dbaa390 SHA512 2c3540acc668aeef4b8f01774219736d95395201ddeaccaf70e0bad4a89f05cdd5ffaf630bae0577656efb3580fae92ce0ee4bb1a720ea757ca59e3fd66e1893
+DIST bitcoin-0.17.1.knots20181229.patches.tar.xz 475988 BLAKE2B ce19ccbbeaac48f24b2833858a186494f84cb54ac380c42104f4d16b0a6acb44bc7a83c1b11311e2c566326d7067530ea5f34404def5f22b4825e2fa15aca22d SHA512 da89f9510ee523c712aa137512dda752ab8d115eb8a45a999aa742555621f557694db34162a1f6979922268a3e22563883ea6d9d9a47e5c7613235c0ff06fda0
DIST bitcoin-v0.16.3.tar.gz 6658712 BLAKE2B 2c20b32ea30aed264115d1bd336b62fa28de69cbf116385508718efd7ff22537c3bd402c0965e0f6ddd8e79fc8b51f388f52f885847d36207a24523e927ca63e SHA512 2da25f56fe9b1f5a81815c14e70ff1a69ec15f742424e2c24d71303a71d57c8050dea5d5ba57425bbe0a01a3995ad9b30f0beea5dbafd1632a627cd3fd9a984d
+DIST bitcoin-v0.17.1.tar.gz 6224852 BLAKE2B efc86768ee2d23db83496ff9e62bc86d10c4d24a7343f4c706a4d336aeb94087b2d496db53e393beb5a9dc228bb9fe957ca89254c2fdaf9980b03029efbac2f8 SHA512 ef911ac6b49075a4f3d8db7f9f4dc59590d49847006fa36d7b8cce1634945d418accd95b12da505df38314fb7768f544863169d4b26b230e88dd627a83947466
EBUILD libbitcoinconsensus-0.16.3.ebuild 2339 BLAKE2B 297cd6c0adafbb99a5b3da6f8a34171fc32b72de86800a4c0f1401906d25e62db6cf7d9f2446dfe2db7d18e7c776fa5fe738d95cc55f21ef1a12124e869dba4d SHA512 a412a06ed2725a8b86adb5b9c245c3b041a2e3fc38c8a4104c8f808aa7877c0343a9159efdb5f4021f13ecd6a923480332fc7150b7acd6b595353d40deb21b59
+EBUILD libbitcoinconsensus-0.17.1.ebuild 2327 BLAKE2B de3360a8d2a84142d6dbcb932d2b3ab5d21e394321ea5ed8adfa41ae46d5101620e68ce820c286612505195f122cb03a2a8dbcc0fae223d9e132c7c853114f28 SHA512 1cf921d7e86cb03c6a458de418ed310ed74caa154fa97cc208bc2be8a304dce7358039ba9f44f8b47508cbe3936429322006870daa57ad702c4f3cffbf542b3a
MISC metadata.xml 679 BLAKE2B 5283fe5aba24ba5d425e68ee4f6b1059378027c116c675d94ffdd44fab28c68ea52434df749a3a906121e2a044e296e8a26975f9653b93e693f3815bddf98d9d SHA512 3a9ccff97c3e952ec4c321184144be64daf4d9a1c03d21cc8aa454162ad1c1d133382cbbf5d21a873ea3bf746ec68c4ed0be0b81e2b562724ca9bd05f481d665
diff --git a/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.17.1.ebuild b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.17.1.ebuild
new file mode 100644
index 000000000000..179444243d2c
--- /dev/null
+++ b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.17.1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+BITCOINCORE_COMMITHASH="ef70f9b52b851c7997a9f1a0834714e3eebc1fd8"
+KNOTS_PV="${PV}.knots20181229"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="Bitcoin Core consensus library"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.17.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+asm knots libressl"
+
+DEPEND="
+ >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/bips.md doc/release-notes.md doc/shared-libraries.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.17.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2018/12/25/release-${PV}/"
+ fi
+}
+
+src_prepare() {
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ fi
+
+ eapply_user
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ $(use_enable asm)
+ --without-qtdbus
+ --without-qrencode
+ --without-miniupnpc
+ --disable-tests
+ --disable-wallet
+ --disable-zmq
+ --with-libs
+ --disable-util-cli
+ --disable-util-tx
+ --disable-bench
+ --without-daemon
+ --without-gui
+ --disable-ccache
+ --disable-static
+ --with-system-libsecp256k1
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}