summaryrefslogtreecommitdiff
path: root/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild')
-rw-r--r--net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild
new file mode 100644
index 000000000000..e73d7c962e84
--- /dev/null
+++ b/net-libs/libbitcoinconsensus/libbitcoinconsensus-0.13.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2010-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="0d719145b018e28d48d35c2646a5962b87c60436"
+BITCOINCORE_LJR_DATE="20170102"
+BITCOINCORE_IUSE="test"
+BITCOINCORE_NEED_LIBSECP256K1=1
+BITCOINCORE_NO_DEPEND="libevent"
+inherit bitcoincore eutils
+
+DESCRIPTION="Bitcoin Core consensus library"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+src_configure() {
+ bitcoincore_conf \
+ --with-libs
+}
+
+src_install() {
+ bitcoincore_src_install
+ dodoc doc/bips.md
+ prune_libtool_files
+}