summaryrefslogtreecommitdiff
path: root/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-libs/libasyncns/libasyncns-0.8-r4.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-libs/libasyncns/libasyncns-0.8-r4.ebuild')
-rw-r--r--net-libs/libasyncns/libasyncns-0.8-r4.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/net-libs/libasyncns/libasyncns-0.8-r4.ebuild b/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
index a09e4fae9e19..a55c87358a01 100644
--- a/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
+++ b/net-libs/libasyncns/libasyncns-0.8-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,6 @@ HOMEPAGE="http://0pointer.de/lennart/projects/libasyncns/"
SRC_URI="http://0pointer.de/lennart/projects/libasyncns/${P}.tar.gz"
SLOT="0"
-
LICENSE="LGPL-2.1"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
@@ -18,12 +17,15 @@ IUSE="doc debug"
BDEPEND="doc? ( app-doc/doxygen )"
-src_prepare() {
- default
+PATCHES=(
# fix libdir in pkgconfig file
- eapply "${FILESDIR}/${P}-libdir.patch"
+ "${FILESDIR}"/${P}-libdir.patch
# fix configure check for res_query
- eapply "${FILESDIR}/${P}-configure-res_query.patch"
+ "${FILESDIR}"/${P}-configure-res_query.patch
+)
+
+src_prepare() {
+ default
eautoreconf
}
@@ -31,8 +33,7 @@ multilib_src_configure() {
# libasyncns uses assert()
use debug || append-cppflags -DNDEBUG
- ECONF_SOURCE=${S} \
- econf \
+ ECONF_SOURCE="${S}" econf \
--disable-lynx \
--disable-static
}
@@ -55,5 +56,5 @@ multilib_src_install() {
}
multilib_src_install_all() {
- find "${D}" -name '*.la' -delete
+ find "${ED}" -name '*.la' -delete || die
}