summaryrefslogtreecommitdiff
path: root/net-libs/libaccounts-glib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /net-libs/libaccounts-glib
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'net-libs/libaccounts-glib')
-rw-r--r--net-libs/libaccounts-glib/Manifest2
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.24-r1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/Manifest b/net-libs/libaccounts-glib/Manifest
index 2af3a2d6e456..4fa4ca6276dc 100644
--- a/net-libs/libaccounts-glib/Manifest
+++ b/net-libs/libaccounts-glib/Manifest
@@ -1,3 +1,5 @@
DIST libaccounts-glib-1.23.tar.gz 127931 BLAKE2B 2379786bb4a658eaba632a1788782a0b5620e69fa058e991a41feeedf5b8f4786592077f237513fde9ed4ea00db015a7dd0be6ad852c265a5b7f8b1180ac01e4 SHA512 88fec1fed7a135375516363e4b7f1330d45a6337bbfb45dd35dabce87097ee4e550e968870541e1b496c2ee3db1bd26e0665f4155f1e64d1cc7b6b74d5b71b5c
+DIST libaccounts-glib-1.24.tar.gz 116578 BLAKE2B d3569ee9d4b92f285f20ab7bc285c62c9817a16f632ad9da83a86ab69e7e3ded74afbcb1307deee788a74796372c0011563ecd293cba4b0e81d15252eae4cf50 SHA512 d4e6906f642c7a196cb42172f31345f58037d528950bee3af2b8cb388aea386056cbaa22f0e7c604a4e00038b231e9ee455f6a1d48f82344cfc0037ad7251b7c
EBUILD libaccounts-glib-1.23.ebuild 855 BLAKE2B 79ed3efe8e876ffc020b9264552228f56d3a7f2794f19275f18d8c45b1956042caf8103fe7fbf1aff5723945a03351fe44b502aac825988087e4e7076107e21d SHA512 ca131867785ab6b6cde4bf8b88c2460fb40b555c4a987cf4f67bb79c9a7d4ae65bdf91aa2583029b98f413bf446aa76a226b55da579bf49b0bb91be41135c162
+EBUILD libaccounts-glib-1.24-r1.ebuild 1191 BLAKE2B 4c969bd411b5d92ec658dfb864ac6609a5754860713b6f49341177bee94580669be60281cc13f931d84700833c100b901b39fdab36e88db04c4ce134a745a3ed SHA512 866c8631bd8fe4128e7f99cf54f88938e4d04a8161fafc9e57c514310523cb2b3344d02b7ca81395f192b9c62bbf5284e3d70e597330c52e41b74af20fa018f3
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.24-r1.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.24-r1.ebuild
new file mode 100644
index 000000000000..b1f40ae0f6ab
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.24-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit meson python-r1 vala vcs-snapshot
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/gobject-introspection:=
+ dev-libs/libxml2
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-libs/check
+ doc? ( dev-util/gtk-doc )
+"
+
+# fails
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ vala_src_prepare
+
+ use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir meson_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir meson_src_compile
+}
+
+src_install() {
+ einstalldocs
+ python_foreach_impl run_in_build_dir meson_src_install
+}