summaryrefslogtreecommitdiff
path: root/net-libs/http-parser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /net-libs/http-parser
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/Manifest4
-rw-r--r--net-libs/http-parser/http-parser-2.9.0-r1.ebuild34
-rw-r--r--net-libs/http-parser/http-parser-99999.ebuild6
3 files changed, 40 insertions, 4 deletions
diff --git a/net-libs/http-parser/Manifest b/net-libs/http-parser/Manifest
index 91f063de4977..a03c595980d7 100644
--- a/net-libs/http-parser/Manifest
+++ b/net-libs/http-parser/Manifest
@@ -1,4 +1,6 @@
DIST http-parser-2.8.1.tar.gz 50731 BLAKE2B 1c4f3f61550f7f8e86d7b47e3986754a108dc979c6232d87ac418f9f8295b88ee43c4a5af150460f707e6ade01f5d435801f980ccbff93369ee0a9dc2eb60656 SHA512 6f52f543d979f39688ccefae236527a8183929b3d30f5370570107b01cf89d0338b448249a81102b78d31615d2e8f6e7c708f8961f55ece08e7d3a40e5ad0883
+DIST http-parser-2.9.0.tar.gz 51324 BLAKE2B 5607f3b3da087ba7d7352e896e209a4fd118428f526cf5465fe86253cc01779c79c867f5db6467df8e3b7bad2ca8675050ef9ed1877a945ced8d3fdd47bfabde SHA512 40acecbf71b9f0b4ae857c74c3ec0784d7f341a0cb83cf82b308387d0c5b56d38b282241aaf8ca93816970f2a9e67989f3d9d456459f3986c29fe51ab520155e
EBUILD http-parser-2.8.1.ebuild 1010 BLAKE2B 41fd9e9bc96b39e583f49ec1c01befc7a0b68af0ae21dfff5523c5a8e54bd141fb7b470e47c7ef7c5ab9eda7a19ec64ce290371307c974e753c5477daa70330f SHA512 e1690bdcb1a2b1bc9f1e255e8d494d0e53f46937f89abf24a8106e1194961213f2f2d72370e81be29e3d1a8568df143c9a7fd80967a5d4df3975ba724e89bd56
-EBUILD http-parser-99999.ebuild 878 BLAKE2B f542c8332672550422d4de016d5921ca6972bcd1395bc466090a3d0f7cb8b2169a3424cfd017e9b42d676fd86bcfcce19577cb0cfa3a69a1948403608e7dda93 SHA512 49b9a884e6518be420614a59457eb6fc58f791e56c9c8ad2da866013331ae6b2413a21921c4298a0f9c9d5cdaf505d45d2368aa97a5d247531acfd1887721c62
+EBUILD http-parser-2.9.0-r1.ebuild 988 BLAKE2B d9bc9eb32473fdb043c382ba95dc52a91ee6b9e2d50cd9051922647fc38d877418df96bfaa8c5ee1dfc47c235b752ff8ad2a343f424b5e7221aa1924f652024c SHA512 75d669298b05089742760207ce4ef40ebf8a0b55ae2fefedfc5e50257ad88b80db2eecb99f3e84be57113503e27f53a0a4933c881989b760ba5d44b5de19a58a
+EBUILD http-parser-99999.ebuild 848 BLAKE2B a34ef61acb4072b1b51e13f4381fc6076b8b5e2693a281d1d41a0a15455ec29532aa7c69e474ecaad23b2230ff0d9894d02302e6940148ae19dafc080b508761 SHA512 b74380f265418b2956102b0d56c34ebbe8a439eb81dfd75f91b80eb266094d19940f29af59d50c894f832499af6aca11710ba14631b6111f5a9ea2c4ff4d1735
MISC metadata.xml 289 BLAKE2B 805f4cc8d1b3649e03fe78b6b9b54e24bb9fd20ce85ebfd26e0b3876a9694de33790fc36fcadb0776a3fffec46b9b9083b419e8db54f19d4f624b9892130e5e8 SHA512 099cab401d2a3b0f7ca10fdbb5d31a9cc1f14dc016d75cfdcce122b6c3250cf17ef0215ca92574b1e64d4dc9bb460b3286be1b6a6d123acd0511a3c25c34a022
diff --git a/net-libs/http-parser/http-parser-2.9.0-r1.ebuild b/net-libs/http-parser/http-parser-2.9.0-r1.ebuild
new file mode 100644
index 000000000000..0d1ea38cc555
--- /dev/null
+++ b/net-libs/http-parser/http-parser-2.9.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="HTTP request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2.9.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+ use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ use static-libs && dolib.a libhttp_parser.a
+}
diff --git a/net-libs/http-parser/http-parser-99999.ebuild b/net-libs/http-parser/http-parser-99999.ebuild
index 06a3f2fa0dca..08127047fc39 100644
--- a/net-libs/http-parser/http-parser-99999.ebuild
+++ b/net-libs/http-parser/http-parser-99999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit git-r3 toolchain-funcs multilib-minimal
DESCRIPTION="HTTP request/response parser for C"
HOMEPAGE="https://github.com/nodejs/http-parser"
-EGIT_REPO_URI="https://github.com/nodejs/http-parser/"
+EGIT_REPO_URI="${HOMEPAGE}"
LICENSE="MIT"
SLOT="0"