summaryrefslogtreecommitdiff
path: root/net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
commit6f8038813c460b4f0572d5ef595cdfa94af3a94d (patch)
tree3509e94070265053394b7f2e30a779d7e60c2064 /net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild
parenteccb70a7f91b2d22582587f26d1a28bb31408b45 (diff)
gentoo resync : 21.05.2019
Diffstat (limited to 'net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild')
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild
deleted file mode 100644
index 61f919fcbe1b..000000000000
--- a/net-libs/gtk-vnc/gtk-vnc-0.8.0-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6,7} )
-GNOME2_LA_PUNT="yes"
-VALA_MIN_API_VERSION="0.16"
-VALA_USE_DEPEND="vapigen"
-
-inherit vala gnome2 python-any-r1
-
-DESCRIPTION="VNC viewer widget for GTK"
-HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="examples +introspection pulseaudio sasl +vala"
-REQUIRED_USE="
- vala? ( introspection )
-"
-
-# libview is used in examples/gvncviewer -- no need
-# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129)
-RDEPEND="
- >=dev-libs/glib-2.30.1:2
- >=dev-libs/libgcrypt-1.4.2:0=
- dev-libs/libgpg-error
- >=net-libs/gnutls-3.0:0=
- >=x11-libs/cairo-1.2
- x11-libs/libX11
- >=x11-libs/gtk+-3.0.0:3[introspection?]
- introspection? ( >=dev-libs/gobject-introspection-0.9.4:= )
- pulseaudio? ( media-sound/pulseaudio )
- sasl? ( dev-libs/cyrus-sasl )
-"
-# Keymap databases code is generated with python3; configure picks up $PYTHON exported from python-any-r1_pkg_setup
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
- >=dev-lang/perl-5
- dev-util/glib-utils
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- vala? (
- $(vala_depend)
- >=dev-libs/gobject-introspection-0.9.4 )
-"
-# eautoreconf requires gnome-common
-
-src_prepare() {
- vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf=(
- $(use_with examples)
- $(use_enable introspection)
- $(use_with pulseaudio)
- $(use_with sasl)
- $(use_enable vala)
- --with-coroutine=gthread
- --without-libview
- --disable-static
- --with-gtk=3.0
- )
-
- gnome2_src_configure ${myconf[@]}
-}