summaryrefslogtreecommitdiff
path: root/net-libs/gnome-online-accounts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /net-libs/gnome-online-accounts
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest2
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.44.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 9064647f772b..eeed4ab152d7 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,3 +1,5 @@
DIST gnome-online-accounts-3.40.1.tar.xz 861220 BLAKE2B 668af9cca8524e25b4f65f41983c527e0cac167317c28f6c451c9c9a6cea18a5774c42acd1cf80cfc707ed62524d1381039fd4f16e3e506d4789372a3db85f4f SHA512 ee7835efe6e1afd6a13f823e17eb93e4a3c55e90764f93a766270ef64f07ed18eff2fce325d8248783d7c6f1c0a7a7fe7512ebb7a8bc0a3e3b33b9037a75b088
+DIST gnome-online-accounts-3.44.0.tar.xz 859564 BLAKE2B 6131094df19d5f282491bd19a97f6e0248b10a5c4db19962a6804523101fb86d6bed7523b46cef91328e0f3c7b6496068594de0689ab1fcb63fd8fb80eece49c SHA512 e70a83b557b816dc7eb22bcd1e4a263044a16c981dfa945a529250ea76e743c9cc73f2ecd4f3006d28a4f3161c7a15dba8bd1416b413c28f4d86d0192755e809
EBUILD gnome-online-accounts-3.40.1.ebuild 2121 BLAKE2B 3fb1d323c8897a2ca8ceb11e976b7a4a801dcb2d4e7f6c8b6f0155aadaef8efa3c912c948c85911a58ba1471b45fec60ecfbe9fb987050a01f355447b3a8c6c7 SHA512 a3a5aff663fa2c12bd615be67442b9b87b7bc3858f1d7fb5352e6ced75e75b1e2d51c27b1e2a9fe3a73cb210066d5a77fc44103f3e98f2c9cae8fab6716da29c
+EBUILD gnome-online-accounts-3.44.0.ebuild 2092 BLAKE2B 6b7450f2fd792d69b8f5edfa687d9c5df3420616cd9f8fa34b0fa9729b2c142d759518b41686083d1e105c16124ccf57661ca76d2ad11341368dcdbed3d00d71 SHA512 68558763f7670f6d632f7ba223ae73cb9a2e22e77631ca3102bad3dd09d0c1972bac43f2c7da942d74b1f413f650d43ff3828ff72b584750188464b93001e7b2
MISC metadata.xml 380 BLAKE2B 0c3c7edbcff0344c8e7929bf525916d8a6c8bec9628c7c20d9c98e81102525e2651e422e10edf53be338bd2a74b6d42396d9f8c0d1b8bfa2576a319236a07987 SHA512 eb224bd0e6ffb92203f9df3c56449dff3aeebd8623bd451810ac99a57cb84b277e5ba53354d36cede6678be209da55cc30386b903e71dbd90bd91623c2d005f1
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.44.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.44.0.ebuild
new file mode 100644
index 000000000000..433f793133ef
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.44.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug gnome +introspection kerberos +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ >=net-libs/webkit-gtk-2.26.0:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5
+ )
+"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+
+src_prepare() {
+ use vala && vala_setup
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+
+ # CONFIG_SHELL for bashisms in bug #829494, patch submitted upstream.
+ # Can be removed in future.
+ CONFIG_SHELL="${BROOT}/bin/bash" gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos) \
+ $(use_enable kerberos fedora) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}