summaryrefslogtreecommitdiff
path: root/net-libs/gnome-online-accounts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-07 01:22:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-07 01:22:59 +0100
commita67cd6675142fbbe7b09fff2361f2961a9031451 (patch)
tree50c9362957d0fe7af9b67eb05a22aac8287e6521 /net-libs/gnome-online-accounts
parent744892aecb5cdf9ca0bbe504f7bbcdfb87b518fc (diff)
gentoo auto-resync : 07:10:2022 - 01:22:59
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest2
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 1ac2058925d3..56ef82d76ea4 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,3 +1,5 @@
DIST gnome-online-accounts-3.44.0.tar.xz 859564 BLAKE2B 6131094df19d5f282491bd19a97f6e0248b10a5c4db19962a6804523101fb86d6bed7523b46cef91328e0f3c7b6496068594de0689ab1fcb63fd8fb80eece49c SHA512 e70a83b557b816dc7eb22bcd1e4a263044a16c981dfa945a529250ea76e743c9cc73f2ecd4f3006d28a4f3161c7a15dba8bd1416b413c28f4d86d0192755e809
+DIST gnome-online-accounts-3.46.0.tar.xz 379464 BLAKE2B 20825f2836e334d3f26222ae0583a7dd27d00528fa0e0a1b67f940ada633e3bd3ec93b251f40c88a850ade7dbe503b9610cd4f982eece368a61c04d0d54181f7 SHA512 727eaf248d70ba8b3874ca500d40e6fead3f76f72aee1b1f383aac57ee71bdb77dab7da3487b3f0fee665130cc61ac8b53f3a1bf1754e5df919fc5c48486c201
EBUILD gnome-online-accounts-3.44.0.ebuild 2089 BLAKE2B 38bb7a0c89c92f4c0ef00b0cb4d935219c59c7b8ccd1681d5140f685a5cb93c1ece18ce0f1a2dec39220797b348ac255a0d70aaf7aa20aeac3096e949e622aa4 SHA512 68e5a9f935256c35dc3bf6c8cc66e0866e850a9125653faa78c1ced29f616096b0809118f7d0b0e72958c8f25a61a84ba32c430c93c9e38fa85317c8f5dfe833
+EBUILD gnome-online-accounts-3.46.0.ebuild 1885 BLAKE2B e50505ddc4b51cf23fd433a1ca83b7ca5281a5680a69393fcf26f8c0b5e0a6d6ed57caabb6c066dbdb9c8d4c954a3c2567800ba57a5cdcb6517d7c28c70a14fa SHA512 3034f054d35144c123cc722ece162ee78a9f1e536d7781d2d048f68baa300b17685707ce9ed8ff645df29aea64411ca242295003619ba562b5407f8722d726e0
MISC metadata.xml 380 BLAKE2B 0c3c7edbcff0344c8e7929bf525916d8a6c8bec9628c7c20d9c98e81102525e2651e422e10edf53be338bd2a74b6d42396d9f8c0d1b8bfa2576a319236a07987 SHA512 eb224bd0e6ffb92203f9df3c56449dff3aeebd8623bd451810ac99a57cb84b277e5ba53354d36cede6678be209da55cc30386b903e71dbd90bd91623c2d005f1
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
new file mode 100644
index 000000000000..cf7e18995da4
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug gnome gtk-doc +introspection kerberos man +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.67.4:2
+ sys-apps/dbus
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ >=x11-libs/gtk+-3.19.12:3
+ >=net-libs/webkit-gtk-2.33.1:4.1
+ >=dev-libs/json-glib-0.16
+ >=app-crypt/libsecret-0.5
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.0:1.0
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5
+ )
+"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ local emesonargs=(
+ -Dgoabackend=true
+ -Dinspector=false
+ -Dexchange=true
+ -Dfedora=false
+ -Dgoogle=true
+ -Dimap_smtp=true
+ $(meson_use kerberos)
+ -Dlastfm=true
+ -Dmedia_server=true
+ -Downcloud=true
+ -Dwindows_live=true
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dman=true
+ $(meson use vala vapi)
+ )
+ meson_src_configure
+}