summaryrefslogtreecommitdiff
path: root/net-libs/gnome-online-accounts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:07:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:07:46 +0100
commit3c0ac23fc220e56b44356d845aaf1b71df69c816 (patch)
tree6d455e0701684270c13f4c6e1f1919ecc2cd04ac /net-libs/gnome-online-accounts
parentf3b17e517082e3c6581428440a122f1a2679e278 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest2
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.24.5.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 22a532facb73..c626b27a2ed1 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,3 +1,5 @@
DIST gnome-online-accounts-3.24.4.tar.xz 1412004 BLAKE2B 96e92eefeedb94563af755367b4932469d8a55bd545324bb1ebffb4798bd0a499aafe9523abc7c707342b1c78f912c499335708dfb3f9a149567b64877f0bbd9 SHA512 6e12f03d3ff9b9c831705f0310923b2c3e0daeee1304bb3dfa52fd17d6df49656f3380a1ffd9f30f75890340fb7ee23f53789e4df357a0aeba4e31667fd9c45a
+DIST gnome-online-accounts-3.24.5.tar.xz 1391332 BLAKE2B 9085cbb0c92bfcd338d5feca7ebdd3e3b15483e47fe29faffb8f9fb474663adeaf8d5cc81673c552652c9444e742f2782fd727c93bf488f5c976bde72d00ddce SHA512 8db35d21f0639e7452ec5cb34455b6d48a77fe0755c525f22e5235abe758f09ad5a4685e5e4912a53def298c76a13b558704a83803b5aabecc13a0f9bc3ae0e4
EBUILD gnome-online-accounts-3.24.4.ebuild 2471 BLAKE2B d5748c5b547daaba2a7eddd8141219d00f102f3522bfd3e7d03547db3a7114a9fb739a7d93a642fdcca6a549734ca4c20bd724fbd2d72b9453d8eae407f143fb SHA512 a7356397015414a0a4908eef03f38cb96286268bda14a82bb996ef2df1bdfde5969b0761b0f4a7ded9c4e4d065f682f16f60559b3af6b946fdb53cfc6b56531d
+EBUILD gnome-online-accounts-3.24.5.ebuild 2473 BLAKE2B f589b5a55606011a556628ec04375cbc47b330100665409a693f8eec7ba15c23de2323b6e5c0f269ca8fc71a118f8a6b493a410b7b7890d569050b353d6b73f6 SHA512 18b212a9b3b3896252eff5d6455adeadea67c8a7f036c2e7018615aec0cd7002babbc431b2d4360d50752a1a5937f7ccd5226970b7f95b7ae61cbc9f5077504d
MISC metadata.xml 473 BLAKE2B 316b4409acb16dbde8349acb5bbdeee6cfe96968bb15e90a2c3d96346f6ead282993a48e6b5ea201d9f0b3293e68259b7cd99bab1399cb6a92e1a0cc7291c197 SHA512 fe0bb40a0e1962c67a0208b6c2b9603ae37966b4427b5141efa7f63163fff3eed542a58400c0ac31e508589074c80d130de56733b55c7b10270e2e89de093a03
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.24.5.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.24.5.ebuild
new file mode 100644
index 000000000000..4acaf6e21902
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.24.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug gnome +introspection kerberos vala" # telepathy"
+REQUIRED_USE="vala? ( introspection )"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really a badly one, bug #494456
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}