summaryrefslogtreecommitdiff
path: root/net-libs/gnome-online-accounts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 06:30:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 06:30:37 +0000
commit12c505f7fcc9ddc89e96ed178df05aceec162d92 (patch)
treee86f8947a554ad913c7a767ea9486b60d3bff912 /net-libs/gnome-online-accounts
parent467e2131896a3030032cd5b0fab2094a045bf9d0 (diff)
gentoo auto-resync : 18:03:2023 - 06:30:37
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest2
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 580f65afda0e..1f92cb767acf 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,4 +1,6 @@
AUX gnome-online-accounts-3.46.0-fix-meson-dependencies.patch 946 BLAKE2B 18bb415247b1fa6e5d24cae781f57812eba367a6317e6c8b426a72435731c0ede8b5b2f85e48991c74470f01af862e7910f74515528f736831cf75644e44a47a SHA512 d2d4e5ec7a074849fad3b76dd366c52d75d2ef39ea8e4573bccfed323a727d9ec99848895f576d72b548db2091af15964697949b0a97ac21996868463da7f354
DIST gnome-online-accounts-3.46.0.tar.xz 379464 BLAKE2B 20825f2836e334d3f26222ae0583a7dd27d00528fa0e0a1b67f940ada633e3bd3ec93b251f40c88a850ade7dbe503b9610cd4f982eece368a61c04d0d54181f7 SHA512 727eaf248d70ba8b3874ca500d40e6fead3f76f72aee1b1f383aac57ee71bdb77dab7da3487b3f0fee665130cc61ac8b53f3a1bf1754e5df919fc5c48486c201
+DIST gnome-online-accounts-3.48.0.tar.xz 382964 BLAKE2B 9b64329415118ca3d44f4662db31d82f262c27b4d8cda8ba9eb05b8e606081ae3eb06b5bf691c165b9bb7cf984fdeba8389390d72a4b3595a7d39b1d6ea11df1 SHA512 67e6c39d38187dc58175f6b694c66a92d9b9152b179db41ee05a8c512db5b16f1dd1eb1503c7d732b09126942abc00206ba956f7a54c6ae7a285a9e3101be7a5
EBUILD gnome-online-accounts-3.46.0.ebuild 1948 BLAKE2B e400df4ac17d6e4416142b7d97586bf62427cc6040298a9cf5ac482f3b606de35789979ef5c2dc330c8f036c0fd29433acb5cf00ced033a19cd6cb2b2f159213 SHA512 1d0301356a0dc12ce75355ab4b20093bb7865c2aa52cad7f5f10980afd6fea58bdd61821bd77c1a6216b66cea82f9e9e788af98011a853ef85c5d9ac6616d435
+EBUILD gnome-online-accounts-3.48.0.ebuild 1889 BLAKE2B 499a008c2fa720ebf78d4bc7b7a45db96cc50b80c217f3f3c6cc19fc9635877cfc6945b9bad2bb1050ddc640dd69c446e0b6eda6ea01d08c7396519fb382596e SHA512 12ecbdb29afde1242811c2545c601eaa6e4faeec659654407b86f509b127848341f981271978178f8e60d705739ad827e4619ac03e8deb60b6cf91c9ec69a70f
MISC metadata.xml 497 BLAKE2B c9f25a548f7d6c51efc6dcd12d2c23ce4121621bccd62b0dd29ea9c83170eb5d91ccdb208362c7d4a246207162bc34f5c9f447baaa079b46a848c64ba26ee9a7 SHA512 9950752a3f1465eca98bc46d691ec3105f9d6806449923189884028e4d591977b2840f515348b948985cc75ec9e389155d4a54c2a460e4fc6c757ca30ad466bc
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild
new file mode 100644
index 000000000000..df3ffad9e548
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.48.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="debug gnome gtk-doc +introspection kerberos man +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.67.4:2
+ sys-apps/dbus
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ >=x11-libs/gtk+-3.19.12:3
+ >=net-libs/webkit-gtk-2.33.1:4.1
+ >=dev-libs/json-glib-0.16
+ >=app-crypt/libsecret-0.5
+ >=net-libs/libsoup-3.0:3.0
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.0:1.0
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5
+ )
+"
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ local emesonargs=(
+ -Dgoabackend=true
+ -Dinspector=false
+ -Dexchange=true
+ -Dfedora=false
+ -Dgoogle=true
+ -Dimap_smtp=true
+ $(meson_use kerberos)
+ -Dlastfm=true
+ -Dmedia_server=true
+ -Downcloud=true
+ -Dwindows_live=true
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ -Dman=true
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}