summaryrefslogtreecommitdiff
path: root/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /net-libs/dleyna-core/dleyna-core-0.6.0.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'net-libs/dleyna-core/dleyna-core-0.6.0.ebuild')
-rw-r--r--net-libs/dleyna-core/dleyna-core-0.6.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild b/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild
new file mode 100644
index 000000000000..d60cf90fb902
--- /dev/null
+++ b/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="utility library for higher level dLeyna libraries"
+HOMEPAGE="https://01.org/dleyna/"
+SRC_URI="https://01.org/sites/default/files/downloads/dleyna/${P}.tar_3.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gupnp-1.2.0:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gupnp-1.2.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}