summaryrefslogtreecommitdiff
path: root/net-libs/czmq/czmq-3.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-libs/czmq/czmq-3.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-libs/czmq/czmq-3.0.2.ebuild')
-rw-r--r--net-libs/czmq/czmq-3.0.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-libs/czmq/czmq-3.0.2.ebuild b/net-libs/czmq/czmq-3.0.2.ebuild
new file mode 100644
index 000000000000..3bbe065064fc
--- /dev/null
+++ b/net-libs/czmq/czmq-3.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="High-level C Binding for ZeroMQ"
+HOMEPAGE="http://czmq.zeromq.org"
+SRC_URI="http://download.zeromq.org/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 hppa x86"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ sys-apps/util-linux
+ net-libs/zeromq
+"
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+"
+
+DOCS=( NEWS AUTHORS )
+
+# Network access
+RESTRICT=test
+
+src_prepare() {
+ use test && AUTOTOOLS_IN_SOURCE_BUILD=1
+ sed -i -e 's|-Werror||g' configure.ac || die
+
+ cat >> src/Makemodule-local.am <<-EOF
+ src_libczmq_la_LDFLAGS += -pthread
+ EOF
+
+ autotools-utils_src_prepare
+}
+
+src_test() {
+ autotools-utils_src_test check-verbose VERBOSE=1
+}
+
+src_install() {
+ autotools-utils_src_install
+ mv "${ED}"/usr/bin/makecert{,-czmq} || die
+ mv "${ED}"/usr/share/man/man1/makecert{,-cmzq}.1 || die
+}
+
+pkg_postinst() {
+ elog "Due to file collisions we moved the makecert tool to makecert-${PN}."
+}