summaryrefslogtreecommitdiff
path: root/net-libs/axtls
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /net-libs/axtls
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'net-libs/axtls')
-rw-r--r--net-libs/axtls/Manifest1
-rw-r--r--net-libs/axtls/axtls-2.1.5-r100.ebuild185
2 files changed, 186 insertions, 0 deletions
diff --git a/net-libs/axtls/Manifest b/net-libs/axtls/Manifest
index 025ca9c59b71..5820cf12e72c 100644
--- a/net-libs/axtls/Manifest
+++ b/net-libs/axtls/Manifest
@@ -4,5 +4,6 @@ AUX config 3064 BLAKE2B baedffe4b9e8696a0f933ba761db3f3b8d4d2cf4b910c22077857a43
AUX explicit-libdir-r1.patch 1578 BLAKE2B 1495850dff9ad1dab1e4820158cff5f706ea3420d664ae2fcb7ae9200790e52fbac093ac510812b80d0eaa177a5d210b6b9c43e80d0317ae4621fe3c18b65c01 SHA512 8e10b10eb6959e309e504a0ff2c16795e258f0fab57b97ffb3b64a6c3b84de8e782cc1697983ed7ff0a05a211e43146ecf39588782e8d3c813a4aa053d94557a
DIST axTLS-2.1.5.tar.gz 1318286 BLAKE2B a4f7cb551f3569fbc9a3a7e0e8faa929a5310fdb412283487fedd4a58e36a65529ebd9aec859027ca6df8e69db85b9f908b56f8d37284548b3984da10774ca3d SHA512 d208b174c31a144a779185e77834a34b0fdd15e8cadf4665b8fd76dcb3207955ed687f3d86d1e60f85d108ecccfd900a76e6d045d16a7182001e0b58da09be18
EBUILD axtls-2.1.5-r1.ebuild 4678 BLAKE2B de0672efc998ede965c0680e0388edbc5f76df9e00649ca77877c8ad10a5d265b6fb99c99a7f49e1172a4e1c3abafe53e576d4f1a6862d8cc1b963befba4b933 SHA512 304a0a97988470d3d9a13969da303f5689c38cd8c5c2a5996ac39db7084bba234d81278ce78aaf243b26446aa228cc909690caa49104d27b006e300774a0dc35
+EBUILD axtls-2.1.5-r100.ebuild 4864 BLAKE2B 223f0ef973d1c949ef5402e2a5704dff9b93807ffb445fe8b7cdc9f48a2437be444748aee13d225a3e7b15d800e292670532fe18ff7ea2a6bc9c74ac56f82cd5 SHA512 9246ae57df933b97adf0666bbb8175d31036cc0f52783c3e27a16ae2d5590976ff1fee42a8c66dbb948f14a46b2be2897134ef615ecba23ab97086cccb284759
EBUILD axtls-2.1.5.ebuild 4672 BLAKE2B fcae6be59c45d8041d395bd73c0f6d6f3d99418a93310ffab9613cbb35e335c67f947ea9fcbf05ee8d317da34fe8733b05608f89004fdfc59e9e0ae6d036527f SHA512 4e103608244c3026cd8dda2967c9635e393c7f288282b63017c409a0e5e89f61496df5c5410163eaac8ad74ffd6b18d063a2f02602a70773df9cc8fe2136d5f9
MISC metadata.xml 632 BLAKE2B b83cd23e97a4fdd09ea7354c1245dd65e54c50b418538c2ef71ae9054626861b6516268fcd37485ba19d1981024c47d869cdce00b276473200a7352c29072b1a SHA512 bfd387d998bcf2a457ff01752b553307b0de430cb9372115b366ab80a10866ede54b8ee149c726aba6f12c8cc3c5ea089dc5b25083e95594d8912e181a8626b0
diff --git a/net-libs/axtls/axtls-2.1.5-r100.ebuild b/net-libs/axtls/axtls-2.1.5-r100.ebuild
new file mode 100644
index 000000000000..aa38483db9fd
--- /dev/null
+++ b/net-libs/axtls/axtls-2.1.5-r100.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single multilib multilib-minimal savedconfig toolchain-funcs user
+
+################################################################################
+# axtls CONFIG MINI-HOWTO
+#
+# Note: axtls is highly configurable and uses mconf, like the linux kernel.
+# You can configure it in a couple of ways:
+#
+# 1) USE="-savedconfig" and set/unset the remaining flags to obtain the features
+# you want, and possibly a lot more.
+#
+# 2) You can create your own configuration file by doing
+#
+# FEATURES="keepwork" USE="savedconfig -*" emerge axtls
+# cd /var/tmp/portage/net-libs/axtls*/work/axTLS
+# make menuconfig
+#
+# Now configure axtls as you want. Finally save your config file:
+#
+# cp config/.config /etc/portage/savedconfig/net-libs/axtls-${PV}
+#
+# where ${PV} is the current version. You can then run emerge again with
+# your configuration by doing
+#
+# USE="savedconfig" emerge axtls
+#
+################################################################################
+
+MY_PN=${PN/tls/TLS}
+
+DESCRIPTION="Embedded client/server TLSv1 SSL library and small HTTP(S) server"
+HOMEPAGE="http://axtls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/axtls/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-code"
+
+LICENSE="BSD GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="httpd cgi-lua cgi-php static static-libs doc"
+
+# TODO: add ipv6, and c#, java, lua, perl bindings
+# Currently these all have some issue
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="
+ httpd? (
+ cgi-lua? ( ${LUA_DEPS} )
+ cgi-php? ( dev-lang/php[cgi] )
+ )"
+
+#Note1: static, cgi-* makes no sense if httpd is not given
+REQUIRED_USE="
+ static? ( httpd )
+ cgi-lua? ( httpd ${LUA_REQUIRED_USE} )
+ cgi-php? ( httpd )"
+
+AXTLS_GROUP="axtls"
+AXTLS_USER="axtls"
+
+pkg_setup() {
+ use cgi-lua && lua-single_pkg_setup
+
+ use httpd && {
+ ebegin "Creating axtls user and group"
+ enewgroup ${AXTLS_GROUP}
+ enewuser ${AXTLS_USER} -1 -1 -1 ${AXTLS_GROUP}
+ }
+}
+
+src_prepare() {
+ tc-export AR CC
+
+ eapply "${FILESDIR}/explicit-libdir-r1.patch"
+
+ #We want CONFIG_DEBUG to avoid stripping
+ #but not for debugging info
+ sed -i -e 's: -g::' config/Rules.mak || die
+ sed -i -e 's: -g::' config/makefile.conf || die
+
+ eapply_user
+
+ multilib_copy_sources
+}
+
+use_flag_config() {
+ cp "${FILESDIR}"/config config/.config || die
+
+ #Respect CFLAGS/LDFLAGS
+ sed -i -e "s:^CONFIG_EXTRA_CFLAGS_OPTIONS.*$:CONFIG_EXTRA_CFLAGS_OPTIONS=\"${CFLAGS}\":" \
+ config/.config || die
+ sed -i -e "s:^CONFIG_EXTRA_LDFLAGS_OPTIONS.*$:CONFIG_EXTRA_LDFLAGS_OPTIONS=\"${LDFLAGS}\":" \
+ config/.config || die
+
+ #The logic is that the default config file enables everything and we disable
+ #here with sed unless a USE flags says to keep it
+ if use httpd; then
+ if ! use static; then
+ sed -i -e 's:^CONFIG_HTTP_STATIC_BUILD:# CONFIG_HTTP_STATIC_BUILD:' \
+ config/.config || die
+ fi
+ if ! use cgi-php && ! use cgi-lua; then
+ sed -i -e 's:^CONFIG_HTTP_HAS_CGI:# CONFIG_HTTP_HAS_CGI:' \
+ config/.config || die
+ fi
+ if ! use cgi-php; then
+ sed -i -e 's:,.php::' config/.config || die
+ fi
+ if ! use cgi-lua; then
+ sed -i -e 's:\.lua,::' \
+ -e 's:lua:php:' \
+ -e 's:^CONFIG_HTTP_ENABLE_LUA:# CONFIG_HTTP_ENABLE_LUA:' \
+ config/.config || die
+ fi
+ if use cgi-lua; then
+ sed -i -e "s:/usr/bin/lua:${LUA}:" config/.config || die
+ fi
+ else
+ sed -i -e 's:^CONFIG_AXHTTPD:# CONFIG_AXHTTPD:' \
+ config/.config || die
+ fi
+
+ emake -j1 oldconfig < <(yes n) > /dev/null
+}
+
+multilib_src_configure() {
+ #Per-ABI substitutions.
+ sed -i -e 's:^LIBDIR.*/lib:LIBDIR = $(PREFIX)/'"$(get_libdir):" \
+ Makefile || die
+
+ #Use CC as the host compiler for mconf
+ sed -i -e "s:^HOSTCC.*:HOSTCC=${CC}:" \
+ config/Rules.mak || die
+
+ if use savedconfig; then
+ restore_config config/.config
+ if [[ -f config/.config ]]; then
+ ewarn "Using saved config, all other USE flags ignored"
+ else
+ ewarn "No saved config, seeding with the default"
+ cp "${FILESDIR}"/config config/.config || die
+ fi
+ emake -j1 oldconfig < <(yes '') > /dev/null
+ else
+ use_flag_config
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use savedconfig; then
+ save_config config/.config
+ fi
+
+ emake PREFIX="${ED}/usr" install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/libaxtls.a || die
+ fi
+
+ # The build system needs to install before it builds docs
+ if multilib_is_native_abi && use doc; then
+ emake docs
+ dodoc -r docsrc/html
+ fi
+}
+
+multilib_src_install_all() {
+ if [[ -f "${ED}"/usr/bin/htpasswd ]]; then
+ mv "${ED}"/usr/bin/{,ax}htpasswd || die
+ fi
+
+ if use httpd; then
+ newinitd "${FILESDIR}"/axhttpd.initd axhttpd
+ newconfd "${FILESDIR}"/axhttpd.confd axhttpd
+ fi
+
+ docompress -x /usr/share/doc/${PF}/README
+ dodoc README
+}