summaryrefslogtreecommitdiff
path: root/net-libs/accounts-qt/accounts-qt-1.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-libs/accounts-qt/accounts-qt-1.16.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-libs/accounts-qt/accounts-qt-1.16.ebuild')
-rw-r--r--net-libs/accounts-qt/accounts-qt-1.16.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-libs/accounts-qt/accounts-qt-1.16.ebuild b/net-libs/accounts-qt/accounts-qt-1.16.ebuild
new file mode 100644
index 000000000000..36384c3ff990
--- /dev/null
+++ b/net-libs/accounts-qt/accounts-qt-1.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 bindings for libaccounts-glib"
+HOMEPAGE="https://accounts-sso.gitlab.io/"
+SRC_URI="https://gitlab.com/accounts-sso/lib${PN}/repository/VERSION_${PV}/archive.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 x86"
+IUSE="doc test"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtxml:5
+ >=net-libs/libaccounts-glib-1.23:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+# dbus problems
+RESTRICT="test"
+
+S="${WORKDIR}/lib${PN}-VERSION_${PV}-525ec684cfa8d234f797d7e49e21c476eea04d8e"
+
+src_prepare() {
+ default
+
+ sed -e "s|share/doc/\$\${PROJECT_NAME}|share/doc/${PF}|" \
+ -i doc/doc.pri || die
+ if ! use doc; then
+ sed -e "/include( doc\/doc.pri )/d" -i ${PN}.pro || die
+ fi
+ if ! use test; then
+ sed -e '/^SUBDIRS/s/tests//' \
+ -i accounts-qt.pro || die "couldn't disable tests"
+ fi
+}
+
+src_configure() {
+ eqmake5 LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}