summaryrefslogtreecommitdiff
path: root/net-libs/NativeThread
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /net-libs/NativeThread
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'net-libs/NativeThread')
-rw-r--r--net-libs/NativeThread/Manifest3
-rw-r--r--net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild (renamed from net-libs/NativeThread/NativeThread-0_pre20190914.ebuild)21
-rw-r--r--net-libs/NativeThread/files/NativeThread-0_pre20190914-javah.patch14
3 files changed, 32 insertions, 6 deletions
diff --git a/net-libs/NativeThread/Manifest b/net-libs/NativeThread/Manifest
index ac4f47f2eb64..96acb7b17093 100644
--- a/net-libs/NativeThread/Manifest
+++ b/net-libs/NativeThread/Manifest
@@ -1,3 +1,4 @@
+AUX NativeThread-0_pre20190914-javah.patch 625 BLAKE2B af0d85e2b477e40c396313e779034c5bed20b42db50a936c473ad4cf15402ed7033c21db5435a44c8d6da67908121408bb18f062d2c321a0ee02cdbb7acb4460 SHA512 51bfb693850da086a118e4bb34da36856be13556bdf15f5374bb4df758e7479fe7988d36c02d8058eac40bbd59daec506fbb08cba270fb942c554b449c6f11af
DIST NativeThread-0_pre20190914.tar.bz2 3163 BLAKE2B b16aa3ceb3ea18ea13962e53d68fa2eac1854b9141055de251eedf0c9a2cc284e68f3f2601f49d1ac1d7fcef9fc502bf1877161fdb43b1b941a3b9983829e4a9 SHA512 ff0902b874c72f0e15f35374d0a409271ba236343cf24bc708bc7a72677a9a582013bfb7a1e8fdd2aabb741bb5dc04dc901ff4c09841a85324194644d40c58e6
-EBUILD NativeThread-0_pre20190914.ebuild 585 BLAKE2B c9d7b1ed765f9d8f2a638ffec5957337800d07354f3d4713ca836027c22f645b432878622cec0ff16aa1745cce6b0ab27903da63674f7eeff2819fc1791cd368 SHA512 cfcb0b6a5ee8d952f6825304f84c9ddd29d8436540494f43396073703edc99ac2a41aae7777153623b0c5ad9f28cbb36a83201091e3ea64e9f149e1c589b16c7
+EBUILD NativeThread-0_pre20190914-r1.ebuild 702 BLAKE2B 2802c599005ea90f31820926a544b9d61347b4314499c922115a11190b554f3dc14ca27686a008bbda80bd00b01d79fbd65ba26cb159e1096d7b8e98742b149a SHA512 e956ee4b37dfe60d8f785822608f028b0310eff9a4d27164cb40f46f301f894dc26fcd8045e1bc1be96758248ac1fa871bfcefde3bc06f41efa2660b941d4273
MISC metadata.xml 257 BLAKE2B 1855912d4ff784d04c925a67130a53838386bd4c491e5c5cf4f218c2a79b538cd9d0d2c79c124832707abeeeee027d6d7a93f1d057e3262e1890084453e2b9af SHA512 dfb4a09792ec2d2b185d1131473c28493b9a3e28aa41f5cbc91354c793c3cc11c763886115037257651f3d6689436396840b2d252a311f318901c94dccec4b9d
diff --git a/net-libs/NativeThread/NativeThread-0_pre20190914.ebuild b/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
index 7d89a6bca773..1156f64a3ad3 100644
--- a/net-libs/NativeThread/NativeThread-0_pre20190914.ebuild
+++ b/net-libs/NativeThread/NativeThread-0_pre20190914-r1.ebuild
@@ -1,24 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic java-pkg-2 toolchain-funcs
DESCRIPTION="NativeThread for priorities on linux for freenet"
-HOMEPAGE="http://www.freenetproject.org/"
+HOMEPAGE="https://www.freenetproject.org/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND=">=net-p2p/freenet-0.7
- >=virtual/jdk-1.4"
-RDEPEND=""
+CDEPEND="
+ dev-java/jna:4
+"
+DEPEND="net-p2p/freenet
+ >=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
S="${WORKDIR}"
+PATCHES=(
+ "${FILESDIR}/${P}-javah.patch"
+)
+
+src_prepare() {
+ default
+}
+
src_compile() {
append-flags -fPIC
tc-export CC
diff --git a/net-libs/NativeThread/files/NativeThread-0_pre20190914-javah.patch b/net-libs/NativeThread/files/NativeThread-0_pre20190914-javah.patch
new file mode 100644
index 000000000000..ceefc8f36d70
--- /dev/null
+++ b/net-libs/NativeThread/files/NativeThread-0_pre20190914-javah.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile b/Makefile
+index 0a879d2..b0b45d1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -9,7 +9,8 @@ libNativeThread.so: NativeThread.c NativeThread.h
+ $(CC) $(CFLAGS) -o libNativeThread.so $(LDFLAGS) NativeThread.c $(LIBS)
+
+ NativeThread.h:
+- javah -o NativeThread.h -classpath /usr/share/freenet/lib/freenet.jar freenet.support.io.NativeThread
++ javac -h . -classpath /usr/share/freenet/lib/freenet.jar:/usr/share/jna-4/lib/jna.jar:/usr/share/jna-4/lib/jna-platform.jar NativeThread.java
++ mv freenet_support_io_NativeThread_LinuxNativeThread.h NativeThread.h
+
+ clean:
+ rm -f NativeThread.h libNativeThread*.so