summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-17 05:02:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-17 05:02:24 +0100
commit58018a2c9504435bb719f2d60439ebe22fbeb503 (patch)
tree7c4241c639fcf98d0a61506786b8b3be9bfef48d /net-irc
parent5017c48e54de7e3dcebd1db96598cf0a07b21f16 (diff)
gentoo auto-resync : 17:09:2023 - 05:02:24
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/Manifest.gzbin8229 -> 8233 bytes
-rw-r--r--net-irc/polari/Manifest2
-rw-r--r--net-irc/polari/polari-45.0.ebuild52
3 files changed, 54 insertions, 0 deletions
diff --git a/net-irc/Manifest.gz b/net-irc/Manifest.gz
index 10be680e773b..f1353f794234 100644
--- a/net-irc/Manifest.gz
+++ b/net-irc/Manifest.gz
Binary files differ
diff --git a/net-irc/polari/Manifest b/net-irc/polari/Manifest
index 686afec8906d..d74fa84ef0fe 100644
--- a/net-irc/polari/Manifest
+++ b/net-irc/polari/Manifest
@@ -1,3 +1,5 @@
DIST polari-43.0.tar.xz 1128316 BLAKE2B 224c70d77ad772aacc5264b2ff15b9371cbfb47bcdaef3b3fd6b55b86e48947b960773e9568f3a6830b1958b2d901ec9d3e3da3cd3fb1c6341a5fa7d34ab5014 SHA512 ff1d96f7e464043616760f378136c3dfb1b5fc3fce3d24fe067540ce0a306d76027681f085ad0030959a6b1653d9f0291e108457305c16849936ab25861fe285
+DIST polari-45.0.tar.xz 1060220 BLAKE2B cca8d79a33b3874d9f13b9110687e0fac3cbc1a9b7a2652f2e315d0ee0b996263946e209da3141763f18293e77127d843beac96155168cb5a24af88ff1de3f85 SHA512 33a3a0ef6960d2ac11fc312efc859a5ea75198c4ae8e74ff0885f9d0aa04f4e59d84be1495db3f498486b595aac66a91ec63d121a92557d9386dfbaed60bb409
EBUILD polari-43.0.ebuild 1058 BLAKE2B 407113d29bdc9a4267c71c0b35ea4c88506a4e228f7716fea889d6b0e6963d4f308460805409f02160843bb3dcdd561007def463b05abb69f710ce78379fd44d SHA512 5f0f3a40bbb078f7632fbd246e95cd055b0083eaecf672ae51e24d17a7488c2e5317627bf0ed3bafb247932bfdcb0ca5c68458ba56fe79dbc7bc29ac7cc36eba
+EBUILD polari-45.0.ebuild 1060 BLAKE2B a7a91674b7650281491d68f23f29256319a9b4f1f6a02ae7ef2ffb4890c0274c0fb7a1ae2b159e8cb5f2deeab569a316f0a74f2092530c9704660304e351ac0d SHA512 7cfd2d8c6169737874eb28b7e7702de23a6e2890be4a9d458e1d666f8a1cae03a38a4007e086d609384f95d1df5e34d78605db4674f2194fbe85b17f0713feef
MISC metadata.xml 347 BLAKE2B b85c094ef47060737f8f7b57071e7b78374ab17226ef793da84e4b6a13792cd8076d6ac060a9c4cda5893a2559cd0bf3e958397fb35908aaf73a462fd496fe97 SHA512 e63acb67ec5073a50302f175f361842ca5b633aba721975f685c9f0d4bcdeb3801e2ad83cae600975f994946682d5ad1ab7da3d682bf4d4bb712a2f64eab82c5
diff --git a/net-irc/polari/polari-45.0.ebuild b/net-irc/polari/polari-45.0.ebuild
new file mode 100644
index 000000000000..4c0fce257d1b
--- /dev/null
+++ b/net-irc/polari/polari-45.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="An IRC client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Polari https://gitlab.gnome.org/GNOME/polari"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ net-libs/telepathy-glib[introspection]
+ >=dev-libs/gobject-introspection-1.50:=
+ >=dev-libs/gjs-1.73.1
+
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=app-text/gspell-1.4.0[introspection]
+ x11-libs/pango[introspection]
+ app-crypt/libsecret[introspection]
+ net-libs/libsoup:3.0[introspection]
+ net-im/telepathy-logger[introspection]
+"
+RDEPEND="${DEPEND}
+ >=net-irc/telepathy-idle-0.2
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ dev-libs/json-glib
+ )
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}