summaryrefslogtreecommitdiff
path: root/net-irc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /net-irc
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/Manifest.gzbin9148 -> 9151 bytes
-rw-r--r--net-irc/eggdrop/Manifest2
-rw-r--r--net-irc/eggdrop/eggdrop-1.8.4.ebuild70
3 files changed, 72 insertions, 0 deletions
diff --git a/net-irc/Manifest.gz b/net-irc/Manifest.gz
index 7e28dfa5d9ca..0207be004b09 100644
--- a/net-irc/Manifest.gz
+++ b/net-irc/Manifest.gz
Binary files differ
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index 676ad8e993b1..7cd7caf90744 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,4 +1,6 @@
AUX eggdrop-installer 2149 BLAKE2B a9b2d7887732f1b6cabb6998ea7c128b52308a70fc46521521d92c1c3bb9f78fd2b32866c62fd0e67b360cfb32921ea900983e2892a9e37d3316364bdaabe26f SHA512 e9a99daff0e73344ab6cf73bb28fa26309b6ec85bcb5cfb84c343fe439a7e1e927960462b5f500af077a7470809d8fe4a2771f34c0727728121d9ba06792c715
DIST eggdrop-1.8.3.tar.gz 1756536 BLAKE2B c2693bc383e1d857fe784d54f34479e73902064196021788ddf21f0bb2910977c643d820d2f6b640bb459b2acbfad8158fc0b29b4d76c588dfd76fee09a6fa25 SHA512 ad3b93d18aaa05d0eb00f1089b68d1f077f316042e64fff511ad1bbac06d35105adcb503490faaac4c9fe720dd45a9f350115b6c5d0f41fe198f228213a7a3a3
+DIST eggdrop-1.8.4.tar.gz 1784738 BLAKE2B a86cdc681ebd9c779b7da20f80ff312e4fc848e0cb0a0b9fa34941c91e1b89db1430126e3d0b94c7b4346c0bde099a6ddd343270943570744c46fc4ddd451540 SHA512 d08af09dc83045bf89eae957e7817591f16456f83ba3efe6b361fd421a3d4068348543275c26b27b006f09f06344c04cdf58ee4231f1aee0e7537ec39bc24b49
EBUILD eggdrop-1.8.3.ebuild 1718 BLAKE2B 6a1e26f655876c6de4aeeb157662d12c5d7fed80016e8a36e18ee829bdef17dff9f4336a54ac891ebf63c414be2aaadb9a07a271dfc9eb79d1484225ba9ddefc SHA512 fbaf51a3ee4ecd4428d4bfff8a2d09b0a09e4b7f9a954906fb7c644cec70e59f7b325655c3e452a31107432f6100c3993e7bc858b818681e1a80ec0fd50deaea
+EBUILD eggdrop-1.8.4.ebuild 1399 BLAKE2B f9815ed0c9b1fa803c0816ff4628af510623f9ca042b1ce76db6d197723c55a8ea96e681a0b2fb1dd175807f3c29925dcd814740d09791ed3d38039020dc3822 SHA512 bd6df9a7c19e318b210720a5669d142646ac18116a483509decf72468c47bfd81d3a024d4de92987fdd6218990d8a4efe02fb300c62edb0ac134802a1d57f61f
MISC metadata.xml 390 BLAKE2B 1eb2981f9dc0339c56fd6a88c09b16c4ceeea6cecb6635f31c7b89d714a529d14ca8a9431d4003075e13a061fd8121e4d654299f2e5c48f6b12311f6f2b9371f SHA512 50fea1a13e327df7612a08b8ac6c5f8cd3ff76a69640ff045cc11e4da482ba6c67d893179d434106f4c739184be0de40a7e20b5717ac51b281ec728595f12708
diff --git a/net-irc/eggdrop/eggdrop-1.8.4.ebuild b/net-irc/eggdrop/eggdrop-1.8.4.ebuild
new file mode 100644
index 000000000000..c629643aa509
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.8.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="https://www.eggheads.org/"
+SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug doc ipv6 ssl static"
+
+DEPEND="
+ dev-lang/tcl:0=
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ sys-apps/gentoo-functions
+ ${DEPEND}
+"
+
+DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
+
+src_configure() {
+ econf $(use_enable ssl tls) \
+ $(use_enable ipv6 ipv6)
+
+ emake config
+}
+
+src_compile() {
+ local target
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ emake DEST="${D}"/opt/eggdrop install
+
+ use doc && HTML_DOCS=( doc/html/. )
+ rm -r "${D}"/opt/eggdrop/doc/html || die
+ DOC_CONTENTS="
+ Additional documentation can be found
+ in ${EPREFIX}/opt/eggdrop/doc
+ "
+ readme.gentoo_create_doc
+ einstalldocs
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
+ fi
+}