summaryrefslogtreecommitdiff
path: root/net-irc/znc/znc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-07 16:19:32 +0000
commit198bd0cd3c1be97f7deb5283fa00048718482de4 (patch)
tree00169eb129b4ca13ceeb4879c4c5b7fb69c3c4fd /net-irc/znc/znc-9999.ebuild
parente0fac29676c44b996e61c06f8d5c92288e46966b (diff)
gentoo auto-resync : 07:11:2023 - 16:19:32
Diffstat (limited to 'net-irc/znc/znc-9999.ebuild')
-rw-r--r--net-irc/znc/znc-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-irc/znc/znc-9999.ebuild b/net-irc/znc/znc-9999.ebuild
index a247a1966b36..1f2334900220 100644
--- a/net-irc/znc/znc-9999.ebuild
+++ b/net-irc/znc/znc-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1 readme.gentoo-r1 systemd
@@ -33,7 +33,11 @@ SLOT="0/${PV}"
IUSE="+icu nls perl python +ssl sasl tcl test +zlib"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} icu )"
+# tests run znc-buildmod which is a Python script
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} icu )
+ test? ( ${PYTHON_REQUIRED_USE} )
+"
# perl is a build-time dependency of modpython
BDEPEND="
@@ -53,6 +57,7 @@ BDEPEND="
)
"
DEPEND="
+ app-crypt/argon2
icu? ( dev-libs/icu:= )
nls? ( dev-libs/boost:=[nls] )
perl? ( >=dev-lang/perl-5.10:= )
@@ -73,7 +78,7 @@ PATCHES=(
)
pkg_setup() {
- if use python; then
+ if use python || use test; then
python-single-r1_pkg_setup
fi
}