summaryrefslogtreecommitdiff
path: root/net-irc/senpai/senpai-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-23 07:23:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-23 07:23:47 +0100
commit8702447e13af0a540c01f75bee0416677bced231 (patch)
treec48f57af58200e8671b2cf0e8685449dffe3a12c /net-irc/senpai/senpai-0.2.0.ebuild
parent7828eef5de9e45f50282e2b1eaf348f1ac7af477 (diff)
gentoo auto-resync : 23:06:2023 - 07:23:46
Diffstat (limited to 'net-irc/senpai/senpai-0.2.0.ebuild')
-rw-r--r--net-irc/senpai/senpai-0.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/senpai/senpai-0.2.0.ebuild b/net-irc/senpai/senpai-0.2.0.ebuild
new file mode 100644
index 000000000000..d53c9251fc34
--- /dev/null
+++ b/net-irc/senpai/senpai-0.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Modern terminal IRC client. NOTICE me :senpai!"
+HOMEPAGE="https://sr.ht/~taiite/senpai"
+SRC_URI="https://git.sr.ht/~taiite/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/alfredfo/${PN}-deps/raw/master/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+BDEPEND="
+ app-text/scdoc
+"
+
+src_compile() {
+ ego build ${GOFLAGS} ./cmd/senpai
+
+ scdoc <doc/senpai.1.scd >doc/senpai.1 || die
+ scdoc <doc/senpai.5.scd >doc/senpai.5 || die
+}
+
+src_install() {
+ dobin senpai
+
+ doman doc/senpai.{1,5}
+ einstalldocs
+}