summaryrefslogtreecommitdiff
path: root/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild')
-rw-r--r--net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild b/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild
new file mode 100644
index 000000000000..4ade54031303
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-0_p20200830.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE=( sqlite )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+MY_COMMIT="9b6b0bc1252daa6e574363d87d04eebd981215a5"
+SRC_URI="https://github.com/fish-face/quasselgrep/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "access postgres db" dev-python/psycopg:2
+}