summaryrefslogtreecommitdiff
path: root/net-irc/ngircd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /net-irc/ngircd
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'net-irc/ngircd')
-rw-r--r--net-irc/ngircd/Manifest2
-rw-r--r--net-irc/ngircd/ngircd-26.1.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/net-irc/ngircd/Manifest b/net-irc/ngircd/Manifest
index 27f5afb40118..37b693fbf2d5 100644
--- a/net-irc/ngircd/Manifest
+++ b/net-irc/ngircd/Manifest
@@ -1,4 +1,6 @@
AUX ngircd.init-r1.d 388 BLAKE2B 10b6d4eb2cd39fe4e3087461cdc15f2ee8f1002e826552e145903b69e16ce46169a2dde19e03af38228ed9ede0473a828aa8cd123ab4a2b043fde448bb180954 SHA512 12e62e23899d1143a35e60bf983c319f72aa13c49123b497963f96317b2990cb2529919336da5a9b5c230e55479c289358261af92d25ef54bd19079908e18158
+DIST ngircd-26.1.tar.gz 562938 BLAKE2B a1a4ca8b6e12a02cb4ba2e07d777cf77051b5330464c91634cfac0b385157ab7c648e3b71151247bc8ee6cc847e84755fdca3d9b4a25205bbb57b8296995dd17 SHA512 4a3ee379dd8d8655a71134c745f750359ceb0512e184db555f65f2bcab68087480365a35680a9ec75b1e6eb0fef23e1cbe0a0e13c3c58d211e5a520a8eeaa71c
DIST ngircd-26.tar.gz 565579 BLAKE2B edd005179a79bbb51a1401f7d580ebf66cb5bf65d1427453c471a4e7e667d7fd6b320c292e9a7993c5fef6beeae88126fefb73284063451b080ecc0d3e6ca0f1 SHA512 2502baf83e3bfca3e6b83c22fe660fee24732ee875b32a7071a489a8babcc08124738142215b55d4f9bd4e94bec3f2a41889ab18324f772b1674b02883cbfb91
+EBUILD ngircd-26.1.ebuild 2190 BLAKE2B e21af4b0deefc9065650f78101138a0d1505506c891254147bb3639b32f0a454fe5308dae1def1e0e06f6dc37899288b44587a89a4b4688e4beaf9fd37127ca2 SHA512 59d69d2c1050bbdcc07121548a3862d4b6b9f0a0884759a0a8b51ea2e289b6a042d7bf1f3dba173992dc97a7de87ed6d169adefb127669e5442d3abafe332699
EBUILD ngircd-26.ebuild 2187 BLAKE2B de64499c0448af9ef9bf156ef4c5fa71ca6573a71baf3bd187ccd440ac27f0d6cfb5cefcf2f9357d57f57077e0b6951916fd946bbff2de01a76ca8e40d2760e9 SHA512 d5bd6005b284b90643fe3444c6cc1a9fec6ef0a5550f9747a803c413625ac17377c33c117d836ccdbcac5e49cd79bae5c897bc13409c00c82b22f5ad8dd2b807
MISC metadata.xml 650 BLAKE2B dd80efa442d59f04e26bb338e371ffa8380a4cdbb630db30e25adbaa930d9f0e4a486bbd05321b8185c23558ad4e29023153a69d1214294c345b46685eb7de86 SHA512 9b8879892c2edc6c7792c22a684f87ae559a43b034ee66f6242e73075012e1f53a33a63fc3ffa62c41f5fd620a4be6c1ffc57a1b62cf42ffa3c032cec4ff743b
diff --git a/net-irc/ngircd/ngircd-26.1.ebuild b/net-irc/ngircd/ngircd-26.1.ebuild
new file mode 100644
index 000000000000..3336bff7a932
--- /dev/null
+++ b/net-irc/ngircd/ngircd-26.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Bug: https://github.com/ngircd/ngircd/issues/261
+WANT_AUTOMAKE=1.11.6
+inherit autotools
+
+DESCRIPTION="An IRC server written from scratch"
+HOMEPAGE="https://ngircd.barton.de/"
+SRC_URI="https://arthur.barton.de/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+IUSE="debug gnutls ident irc-plus +ipv6 libressl pam +ssl strict-rfc tcpd test zlib"
+
+#RESTRICT="!test? ( test )"
+# Flaky test needs investigation (bug 719256)
+RESTRICT="test"
+
+RDEPEND="
+ acct-user/ngircd
+ acct-group/ngircd
+ irc-plus? ( virtual/libiconv )
+ ident? ( net-libs/libident )
+ pam? ( sys-libs/pam )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+ zlib? ( sys-libs/zlib )
+"
+
+BDEPEND="sys-devel/automake:1.11"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-tcltk/expect
+ net-misc/netkit-telnetd
+ )
+"
+
+src_prepare() {
+ default
+
+ if ! use prefix; then
+ sed -i \
+ -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
+ -e "s:;ServerGID = 65534:ServerGID = ngircd:" \
+ doc/sample-ngircd.conf.tmpl || die
+ fi
+
+ # Once https://github.com/ngircd/ngircd/pull/270 is in a release (ngircd 26), we can remove
+ # the eautomake/autotools machinery.
+ eautomake
+}
+
+src_configure() {
+ local myconf=(
+ --sysconfdir="${EPREFIX}"/etc/"${PN}"
+ $(use_enable debug sniffer)
+ $(use_enable debug)
+ $(use_enable irc-plus ircplus)
+ $(use_enable ipv6)
+ $(use_enable strict-rfc)
+ $(use_with irc-plus iconv)
+ $(use_with ident)
+ $(use_with pam)
+ $(use_with tcpd tcp-wrappers)
+ $(use_with zlib)
+ )
+
+ if use ssl; then
+ if use gnutls; then
+ myconf+=(
+ $( use_with gnutls )
+ )
+ else
+ myconf+=(
+ $( use_with !gnutls openssl )
+ )
+ fi
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/ngircd.init-r1.d ngircd
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] && use pam; then
+ elog "ngircd will use PAMIsOptionalPAM by default, please change this option."
+ elog "You may not be able to login until you change this."
+ fi
+}