summaryrefslogtreecommitdiff
path: root/net-irc/ircii/ircii-20111115.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/ircii/ircii-20111115.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/ircii/ircii-20111115.ebuild')
-rw-r--r--net-irc/ircii/ircii-20111115.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/ircii/ircii-20111115.ebuild b/net-irc/ircii/ircii-20111115.ebuild
new file mode 100644
index 000000000000..72b797c9b94c
--- /dev/null
+++ b/net-irc/ircii/ircii-20111115.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="ftp://ircii.warped.com/pub/ircII/${P}.tar.bz2
+ ftp://ircii.warped.com/pub/ircII/old/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6"
+
+DEPEND="sys-libs/ncurses
+ virtual/libiconv"
+# This and irc-client both install /usr/bin/irc #247987
+RDEPEND="${DEPEND}
+ !!net-irc/irc-client"
+
+src_configure() {
+ tc-export CC
+ econf $(use_enable ipv6)
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc ChangeLog INSTALL NEWS README \
+ doc/Copyright doc/crypto doc/VERSIONS doc/ctcp
+}