summaryrefslogtreecommitdiff
path: root/net-irc/eiwic/eiwic-1.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/eiwic/eiwic-1.1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/eiwic/eiwic-1.1.4.ebuild')
-rw-r--r--net-irc/eiwic/eiwic-1.1.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-irc/eiwic/eiwic-1.1.4.ebuild b/net-irc/eiwic/eiwic-1.1.4.ebuild
new file mode 100644
index 000000000000..e8a0f598cfc9
--- /dev/null
+++ b/net-irc/eiwic/eiwic-1.1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+WANT_AUTOMAKE=1.10
+inherit autotools eutils multilib
+
+DESCRIPTION="A modular IRC bot written in C"
+HOMEPAGE="https://github.com/lordi/Eiwic"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug doc ipv6"
+
+DOCS="AUTHORS ChangeLog README NEWS TODO sample.conf"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.3-ldflags.patch
+
+ sed -i \
+ -e "/^set MODULE_PATH/s:modules:/usr/$(get_libdir)/eiwic:" \
+ -e "/^load MODULE/s:$:.so:" \
+ sample.conf || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_lib_raptor_raptor_init=no #409417
+
+ econf \
+ $(use_enable debug vv-debug) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/*
+}
+
+pkg_postinst() {
+ elog "You need a configuration file to run eiwic. A sample configuration"
+ elog "was installed to /usr/share/doc/${PF}"
+}