summaryrefslogtreecommitdiff
path: root/net-irc/bnc/bnc-2.9.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/bnc/bnc-2.9.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/bnc/bnc-2.9.4-r1.ebuild')
-rw-r--r--net-irc/bnc/bnc-2.9.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-irc/bnc/bnc-2.9.4-r1.ebuild b/net-irc/bnc/bnc-2.9.4-r1.ebuild
new file mode 100644
index 000000000000..73bbb522e5cd
--- /dev/null
+++ b/net-irc/bnc/bnc-2.9.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/-/}"
+DESCRIPTION="BNC (BouNCe) is used as a gateway to an IRC Server"
+HOMEPAGE="http://gotbnc.com/"
+SRC_URI="http://gotbnc.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ppc ppc64 ~s390 sparc x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/respect-cflags-ldflags.patch"
+ "${FILESDIR}/${PN}-2.9.3-64bit.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e 's:./mkpasswd:/usr/bin/bncmkpasswd:' bncsetup \
+ || die 'failed to rename mkpasswd in bncsetup'
+}
+
+src_configure() {
+ econf $(use_with ssl)
+}
+
+src_install() {
+ default
+ mv "${D}"/usr/bin/{,bnc}mkpasswd \
+ || die 'failed to rename the mkpasswd executable'
+ dodoc example.conf motd
+}
+
+pkg_postinst() {
+ einfo 'You can find an example motd/conf file here:'
+ einfo " /usr/share/doc/${PF}"
+}