summaryrefslogtreecommitdiff
path: root/net-irc/anope/anope-2.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-irc/anope/anope-2.0.6.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-irc/anope/anope-2.0.6.ebuild')
-rw-r--r--net-irc/anope/anope-2.0.6.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-irc/anope/anope-2.0.6.ebuild b/net-irc/anope/anope-2.0.6.ebuild
index 1cf036e12d83..2953f690d0dc 100644
--- a/net-irc/anope/anope-2.0.6.ebuild
+++ b/net-irc/anope/anope-2.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils user
+inherit cmake user
DESCRIPTION="Anope IRC Services"
HOMEPAGE="https://anope.org"
@@ -98,7 +98,7 @@ src_prepare() {
# Avoid a silly sandbox error - tries to delete /usr/lib/modules
sed -i '/install.*REMOVE_RECURSE.*/d' CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -111,11 +111,11 @@ src_configure() {
-DCONF_DIR="/etc/anope"
-DLOGS_DIR="../var/log/anope/"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
newinitd "${FILESDIR}/anope-init.d" "${PN}"
cp "${FILESDIR}/anope-conf.d-v2" "${T}" || die
sed -i "s~%LIBDIR%~${EPREFIX}/usr/$(get_libdir)/anope/~" \