summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /net-im
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Manifest.gzbin9407 -> 9573 bytes
-rw-r--r--net-im/profanity/Manifest3
-rw-r--r--net-im/profanity/metadata.xml16
-rw-r--r--net-im/profanity/profanity-0.6.0.ebuild39
4 files changed, 58 insertions, 0 deletions
diff --git a/net-im/Manifest.gz b/net-im/Manifest.gz
index d3faf324e6c6..c12b9d83187d 100644
--- a/net-im/Manifest.gz
+++ b/net-im/Manifest.gz
Binary files differ
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
new file mode 100644
index 000000000000..024cd7382d22
--- /dev/null
+++ b/net-im/profanity/Manifest
@@ -0,0 +1,3 @@
+DIST profanity-0.6.0.tar.gz 741812 BLAKE2B ba6cff070ee0e8a83b52677f6551c1d7397cd25993982d6b5390590a4924d902050504cb8803ee2741262b1409e4d75e9f223397f87f39d7dc86fcc56a0e5df6 SHA512 c7d8e74b764276f59fccfa029d45271032db315cdbf6e00deccbd611f202983a0930fed99021202333047acee9f3f0d7779cd9bb3628d2e5c4757e3de8c3629e
+EBUILD profanity-0.6.0.ebuild 809 BLAKE2B f9033748c2fd6e2a7bfd6bd68d45a6c99308c81d35ccf267c2fc87db204fdfdd9c8eb5f6d87ec5e7d9d162a1a270264c630cd85faf93c303113d2a6461258811 SHA512 817942d90d40c46e04ce07783156233541b998af069732f582c067d07b240c8690b2986160038142c8b6889c481895d81d40f12ca1a3db27b6948291017b1eb1
+MISC metadata.xml 553 BLAKE2B 7580def538562752bce746999e9a88f0a360a0306adb9ccb4ae5dd2d4e860f97e788431908b914abb6ff2e464b0df9fb839539321c1f24a2771929a03772dee2 SHA512 0674f49da08edb45f8dc37d944d8c3379b054fad5892a7da58a8b16ee15e9c839afefdb49e177befde93ae8e856257a9d9f4f1349a9f67201ccbe8da0a5a37d1
diff --git a/net-im/profanity/metadata.xml b/net-im/profanity/metadata.xml
new file mode 100644
index 000000000000..d2349017e1a3
--- /dev/null
+++ b/net-im/profanity/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <longdescription>
+ Profanity is a console based XMPP client written in C using
+ ncurses and libstrophe, inspired by Irssi.
+ </longdescription>
+ <use>
+ <flag name="gpg">Enable OpenPGP encryption</flag>
+ <flag name="otr">Enable encrypted conversations using Off-The-Records messaging</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-im/profanity/profanity-0.6.0.ebuild b/net-im/profanity/profanity-0.6.0.ebuild
new file mode 100644
index 000000000000..402ca75c0859
--- /dev/null
+++ b/net-im/profanity/profanity-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="http://www.profanity.im/"
+SRC_URI="http://www.profanity.im/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify otr gpg xscreensaver"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode]
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}