summaryrefslogtreecommitdiff
path: root/net-im/whatsie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 23:35:30 +0100
commit47d5e233005d470dbd431a280e64ce6073fc7149 (patch)
tree135efe53d72c541429f68d7ed82186f2b34fcdb6 /net-im/whatsie
parentbac9556f73da9ac333933778ce81c053bd989a26 (diff)
gentoo auto-resync : 09:04:2023 - 23:35:30
Diffstat (limited to 'net-im/whatsie')
-rw-r--r--net-im/whatsie/Manifest3
-rw-r--r--net-im/whatsie/metadata.xml11
-rw-r--r--net-im/whatsie/whatsie-4.13.0.ebuild39
3 files changed, 53 insertions, 0 deletions
diff --git a/net-im/whatsie/Manifest b/net-im/whatsie/Manifest
new file mode 100644
index 000000000000..f902ce121fde
--- /dev/null
+++ b/net-im/whatsie/Manifest
@@ -0,0 +1,3 @@
+DIST whatsie-4.13.0.tar.gz 21145212 BLAKE2B f53549fe4975da0c5fad140568b228cb3cbdf93308cba0ddcd5aa3370ed40a84d4463e589edd1d587659b67fceb6885370b826d1746d0f31f292df1d891b3c04 SHA512 ac2b89d14c64b17a1715510754fac5b0f02528250b78fbd5dcfb782d7243ccea43d01e1dcc8507bf3056b94b3d283d9f6359451a80525c58f7889f34cc77805a
+EBUILD whatsie-4.13.0.ebuild 772 BLAKE2B f91e8699a5c33daa56316e6a0cd8256d092dde86e7540a6b7c697f5408d82defd46033eec4338e01b6c71b94b3161037d8af8514189d4a88d9f115a640721fae SHA512 8edb865b266b3b08a2e2e9f8518c94c96518da18d3894b84a81c15cb09bdc5e23ee7a4d1450c9c7d1416256eb61b0645da363ba6a06772112f32a09f29e849bd
+MISC metadata.xml 343 BLAKE2B 94e9a06e3df02122b845cd1ecbbae8d912d521478bdfa7b7934c9e7179a5002be0daba7282e1247315c2ddb5d8f309e75c40833df0bd14ff650fdde878137a76 SHA512 3389c1a46efb8e42aa2762bc9e504456685ccdbf36e716576e6fcb1ae4a5cc2ea0f9f3b9dce594a5813fc79a0b39e29e29852efdf449e0a14078a9c3f48e8239
diff --git a/net-im/whatsie/metadata.xml b/net-im/whatsie/metadata.xml
new file mode 100644
index 000000000000..cbf7db3cb5c1
--- /dev/null
+++ b/net-im/whatsie/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">keshavbhatt/whatsie</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/whatsie/whatsie-4.13.0.ebuild b/net-im/whatsie/whatsie-4.13.0.ebuild
new file mode 100644
index 000000000000..cecf52d1bc2d
--- /dev/null
+++ b/net-im/whatsie/whatsie-4.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Qt Based WhatsApp Client"
+HOMEPAGE="https://github.com/keshavbhatt/whatsie"
+SRC_URI="https://github.com/keshavbhatt/whatsie/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+QT_MIN="5.15"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ >=dev-qt/qtcore-${QT_MIN}:5
+ >=dev-qt/qtgui-${QT_MIN}:5
+ >=dev-qt/qtnetwork-${QT_MIN}:5
+ >=dev-qt/qtpositioning-${QT_MIN}:5
+ >=dev-qt/qtwebengine-${QT_MIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QT_MIN}:5
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ einstalldocs
+ INSTALL_ROOT="${ED}" emake install
+}