summaryrefslogtreecommitdiff
path: root/net-im/webex/webex-41.5.0.18911.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /net-im/webex/webex-41.5.0.18911.1-r2.ebuild
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'net-im/webex/webex-41.5.0.18911.1-r2.ebuild')
-rw-r--r--net-im/webex/webex-41.5.0.18911.1-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-im/webex/webex-41.5.0.18911.1-r2.ebuild b/net-im/webex/webex-41.5.0.18911.1-r2.ebuild
new file mode 100644
index 000000000000..7e2ebf186457
--- /dev/null
+++ b/net-im/webex/webex-41.5.0.18911.1-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg rpm
+
+DESCRIPTION="Cisco video conferencing and online meeting software"
+HOMEPAGE="https://www.webex.com/"
+SRC_URI="https://binaries.webex.com/WebexDesktop-CentOS-Official-Package/Webex.rpm -> ${P}.rpm"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror strip"
+
+DEPEND=""
+
+# systemd-libs => virtual/libudev
+RDEPEND="
+ media-libs/alsa-lib
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libnotify
+ app-crypt/libsecret
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ sys-apps/lshw
+ media-libs/libglvnd
+ media-libs/mesa
+ dev-libs/nss
+ x11-libs/pango
+ media-sound/pulseaudio
+ virtual/libudev
+ sys-power/upower
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ || (
+ sys-libs/glibc[crypt(+)]
+ sys-libs/libxcrypt[compat]
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_install() {
+ mv opt "${D}/" || die
+
+ # dodir /usr/lib/debug
+ # mv usr/lib/.build-id "${D}/usr/lib/debug/" || die
+
+ sed -e 's:Utility;Application;:Network;InstantMessaging;:g' -i "${D}/opt/Webex/bin/webex.desktop"
+ sed -e '/^Version=.*$/d' -i "${D}/opt/Webex/bin/webex.desktop"
+
+ domenu "${D}/opt/Webex/bin/webex.desktop"
+ doicon "${D}/opt/Webex/bin/sparklogosmall.png"
+}