summaryrefslogtreecommitdiff
path: root/net-im/toxic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /net-im/toxic
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'net-im/toxic')
-rw-r--r--net-im/toxic/Manifest2
-rw-r--r--net-im/toxic/toxic-0.10.1.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/net-im/toxic/Manifest b/net-im/toxic/Manifest
index 8ad2d534e9e2..744cf33e22b0 100644
--- a/net-im/toxic/Manifest
+++ b/net-im/toxic/Manifest
@@ -1,5 +1,7 @@
DIST toxic-0.10.0.tar.gz 1160161 BLAKE2B 30089398211945f366fd7b52ab4014cd9b020f58b7d3e47ec1a12a87055f10cdb723211f38d1028a3fb149cd76aa7771591e37f7961cda37b7bcbb8e21b33181 SHA512 bfbe8e4c90b4fcbdbe7cc96cb402e4c2f1609e2970e51d6d2ad2c8596350ce96ac9f4d06fbb71350e56d8892e2ed4ee8c5adf4f66cdad6b152c959802bddc6cc
+DIST toxic-0.10.1.tar.gz 1165118 BLAKE2B d367039bef9c97c23c8e5453b607cf72f70776e8c86c41da0480eb04725a901bf33bb89727aee3010ad97d33ef2aa653ff09ea49b597cdf2008ff976c395065c SHA512 aec2e6612d639e0210ae68db3368b656647575e3d927444d0726422ff2cf9718dd5a8b3f37a8253cdc3714f09f9f96828dfccf7a7ae12f8a41ce3207f92a684d
DIST toxic-0.8.3.tar.gz 1147100 BLAKE2B d73a861112aca65e54773c98473c2858bb81e63fef11212633e34dac9e87101956e3ab0d9d56757767bc5d48d1d5a406e550f8fc55ae34860dbc4977c94ee347 SHA512 c8d746efcc055592dd990dfa57415cc1eacaaa3b66303d7583d9f9e7e98b8829c8f1ae849f36a243c8896e99787dd2e493c92367de719b20a4a160bc7daea76e
EBUILD toxic-0.10.0-r1.ebuild 2714 BLAKE2B 5473d9c4b78e94abe0827f9b8191cfd1f44b42ee5c07ef22c38be41474c812d542380a4af0f4b655e6590d4abaeff4fbdf67e3f802ccf48f98732b0a55c6c19f SHA512 bdf5e716b072843570bfbafa234b636871e71e20dbcf2a20a5b4e455e26ef104c78634a8bf854a3dd214cdd114768d6efb4111f061755ba3db266d0824d39ee7
+EBUILD toxic-0.10.1.ebuild 2697 BLAKE2B 1d9745a20a753ac3bf38cc9ae14ad85b24f99df947bb6a5bc7d057c23afd6b9d65897336c0574411bd41a51fbaf3b3b459256acf18bfca827c70b97f2594340a SHA512 5cce18abf16ec4d64034df723c56cc72a09cef70d2f09ac14d746379f4e78132cddb82898d9ba8955be5dae2d33c5838ea114e724ef567348a20b0bfea10564d
EBUILD toxic-0.8.3-r2.ebuild 1817 BLAKE2B 73f8276337997cc2ea695cf691a47241ba981d414d6055b6f466503db0e79a14985cd1e08736570196c3196119f1db60edc668b5f271dfeca8dc2352b06682de SHA512 d94d058e687405ab6361babd1f3a8e7b8d98d456c4b7a8f06d55a7831cf88eedf041e778b605731d130baef1839b993280bfcf92ec7d54b46b703a56e8f69d29
MISC metadata.xml 1154 BLAKE2B 5f94676351ad071b3278cc986d715ac5980fafa89a2be08253ac05787027b7a4cdbd3a9de8c88fece1ad35c8442956cbd089568d3c340f3ad6832186ed1d341b SHA512 2a65c022688774e5f892e7be3e69283e17164a47484f311544bc1bacbf3c5374c80736568adaa00db9b18f2ae1ff8946cc6a7c0912aaeb0a2c3b33f42ab7609b
diff --git a/net-im/toxic/toxic-0.10.1.ebuild b/net-im/toxic/toxic-0.10.1.ebuild
new file mode 100644
index 000000000000..4f0639961dc5
--- /dev/null
+++ b/net-im/toxic/toxic-0.10.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="A curses-based client for Tox"
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+audio-notify debug doc llvm notification png python qrcode +sound +video +X"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ video? ( sound X ) "
+
+RDEPEND="dev-libs/libconfig:=
+ net-libs/tox:=
+ net-misc/curl
+ sys-libs/ncurses:=
+ audio-notify? (
+ media-libs/freealut
+ media-libs/openal
+ )
+ notification? ( x11-libs/libnotify )
+ debug? ( llvm? ( sys-devel/llvm:* ) )
+ python? ( ${PYTHON_DEPS} )
+ qrcode? (
+ media-gfx/qrencode:=
+ png? ( media-libs/libpng )
+ )
+ sound? (
+ media-libs/openal
+ net-libs/tox:=[av]
+ )
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libX11
+ )"
+
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ #prevent man files from being compressed.
+ sed -i -e "/gzip/d" cfg/targets/install.mk || die "Unable to prevent compression of man pages."
+ #Fix incorrect linkage of pthread (may be optional)
+ sed -i -e 's/pthread/lpthread/g' Makefile || die "Unable to fix linking of pthread."
+ #Makefile sets some required CFLAGS only if CFLAGS variable is undefined,
+ #This line changes the "lazy set if absent" assignment to a "lazy set" assignment.
+ #look below in src_configure to see how CFLAGS are passed to the makefile in USER_CFLAGS
+ sed -i -e 's/?=/=/g' Makefile || die "Unable to force CFLAGS and LDFLAGS"
+}
+
+src_configure() {
+ if ! use audio-notify; then
+ USER_CFLAGS+="-DDISABLE_SOUND_NOTIFY=1 "
+ fi
+ if use debug; then
+ USER_CFLAGS+="-DENABLE_RELEASE=0 "
+ if use llvm; then
+ USER_CFLAGS+="-DENABLE_ASAN=1 "
+ fi
+ fi
+ if ! use notification; then
+ USER_CFLAGS+="-DDISABLE_DESKTOP_NOTIFY=1 "
+ fi
+ if ! use png; then
+ USER_CFLAGS+="-DDISABLE_QRPNG=1 "
+ fi
+ if use python; then
+ USER_CFLAGS+="-DENABLE_PYTHON=1"
+ fi
+ if ! use qrcode; then
+ USER_CFLAGS+="-DDISABLE_QRCODE=1"
+ fi
+ if ! use sound; then
+ USER_CFLAGS+="-DDISABLE_AV=1 "
+ fi
+ if ! use video; then
+ USER_CFLAGS+="-DDISABLE_VI=1"
+ fi
+ if ! use X; then
+ USER_CFLAGS+="-DDISABLE_X11=1 "
+ fi
+ USER_CFLAGS+="${CFLAGS}"
+ export USER_CFLAGS
+ export USER_LDFLAGS="${LDFLAGS}"
+ #set install directory to /usr.
+ sed -i -e "s,/usr/local,${EPREFIX}/usr,g" cfg/global_vars.mk || die "Failed to set install directory!"
+}
+
+src_install() {
+ default
+ if ! use audio-notify; then
+ rm -r "${ED}"/usr/share/${PN}/sounds || die "Could not remove sounds directory"
+ fi
+}