summaryrefslogtreecommitdiff
path: root/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild')
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
new file mode 100644
index 000000000000..f54b59cbc4d3
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="https://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug networkmanager" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.46:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-1:= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/5.16.5-account-fix-property-name.patch" )
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ --disable-upower \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm)
+}