summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /net-im/telegram-desktop/files
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'net-im/telegram-desktop/files')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.7.3-disable-webkit-separately.patch80
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.7.3-webview-include-gdkx.patch12
2 files changed, 92 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-2.7.3-disable-webkit-separately.patch b/net-im/telegram-desktop/files/tdesktop-2.7.3-disable-webkit-separately.patch
new file mode 100644
index 000000000000..a143071401a9
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.7.3-disable-webkit-separately.patch
@@ -0,0 +1,80 @@
+Index: tdesktop-2.7.3-full/Telegram/lib_webview/CMakeLists.txt
+===================================================================
+--- tdesktop-2.7.3-full.orig/Telegram/lib_webview/CMakeLists.txt
++++ tdesktop-2.7.3-full/Telegram/lib_webview/CMakeLists.txt
+@@ -116,7 +116,7 @@ if (WIN32)
+ desktop-app::lib_webview_winrt
+ )
+ elseif (LINUX)
+- if (NOT DESKTOP_APP_DISABLE_GTK_INTEGRATION)
++ if (NOT DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION)
+ find_package(PkgConfig REQUIRED)
+
+ if (DESKTOP_APP_USE_PACKAGED AND NOT DESKTOP_APP_USE_PACKAGED_LAZY)
+Index: tdesktop-2.7.3-full/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
+===================================================================
+--- tdesktop-2.7.3-full.orig/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
++++ tdesktop-2.7.3-full/Telegram/lib_webview/webview/platform/linux/webview_linux.cpp
+@@ -11,14 +11,14 @@
+ namespace Webview {
+
+ Available Availability() {
+-#ifndef DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#ifndef DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
+ return WebKit2Gtk::Availability();
+-#else // !DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#else // !DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
+ return Available{
+ .error = Available::Error::NoGtkOrWebkit2Gtk,
+ .details = "This feature was disabled at build time.",
+ };
+-#endif // DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#endif // DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
+ }
+
+ bool SupportsEmbedAfterCreate() {
+@@ -26,11 +26,11 @@ bool SupportsEmbedAfterCreate() {
+ }
+
+ std::unique_ptr<Interface> CreateInstance(Config config) {
+-#ifndef DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#ifndef DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
+ return WebKit2Gtk::CreateInstance(std::move(config));
+-#else // !DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#else // !DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
+ return nullptr;
+-#endif // DESKTOP_APP_DISABLE_GTK_INTEGRATION
++#endif // DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
+ }
+
+ } // namespace Webview
+Index: tdesktop-2.7.3-full/cmake/options.cmake
+===================================================================
+--- tdesktop-2.7.3-full.orig/cmake/options.cmake
++++ tdesktop-2.7.3-full/cmake/options.cmake
+@@ -49,6 +49,13 @@ if (DESKTOP_APP_DISABLE_GTK_INTEGRATION)
+ )
+ endif()
+
++if (DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION)
++ target_compile_definitions(common_options
++ INTERFACE
++ DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION
++ )
++endif()
++
+ if (DESKTOP_APP_USE_PACKAGED)
+ target_compile_definitions(common_options
+ INTERFACE
+Index: tdesktop-2.7.3-full/cmake/variables.cmake
+===================================================================
+--- tdesktop-2.7.3-full.orig/cmake/variables.cmake
++++ tdesktop-2.7.3-full/cmake/variables.cmake
+@@ -32,6 +32,7 @@ option(DESKTOP_APP_DISABLE_DBUS_INTEGRAT
+ option(DESKTOP_APP_DISABLE_X11_INTEGRATION "Disable all code for X11 integration (Linux only)." OFF)
+ option(DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION "Disable all code for Wayland integration (Linux only)." OFF)
+ option(DESKTOP_APP_DISABLE_GTK_INTEGRATION "Disable all code for GTK integration (Linux only)." OFF)
++option(DESKTOP_APP_DISABLE_WEBKIT_INTEGRATION "Disable all code for WebkitGTK integration (Linux only)." OFF)
+ option(DESKTOP_APP_USE_GLIBC_WRAPS "Use wraps for new GLIBC features." OFF)
+ option(DESKTOP_APP_USE_PACKAGED "Find libraries using CMake instead of exact paths." ${no_special_target})
+ option(DESKTOP_APP_USE_PACKAGED_LAZY "Bundle recommended Qt plugins for self-contained packages. (Linux only)" OFF)
diff --git a/net-im/telegram-desktop/files/tdesktop-2.7.3-webview-include-gdkx.patch b/net-im/telegram-desktop/files/tdesktop-2.7.3-webview-include-gdkx.patch
new file mode 100644
index 000000000000..2f06bda3272a
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.7.3-webview-include-gdkx.patch
@@ -0,0 +1,12 @@
+Index: tdesktop-2.7.3-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
+===================================================================
+--- tdesktop-2.7.3-full.orig/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
++++ tdesktop-2.7.3-full/Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
+@@ -12,6 +12,7 @@ extern "C" {
+ #undef signals
+ #include <JavaScriptCore/JavaScript.h>
+ #include <gtk/gtk.h>
++#include <gdk/gdkx.h>
+ #include <webkit2/webkit2.h>
+ #include <X11/Xlib.h>
+ #define signals public